Scijava AnnotationProcessor warning

During compilation I get the followin warning:
Warning:java: Supported source version 'RELEASE_6' from annotation processor 'org.scijava.annotations.AnnotationProcessor' less than -source '1.8'

I am not sure if it is refering to the java or the plugin version.
(using pom-fiji 23.0.0)

Hi Felix,

The error is referring to the Maven setup of SciJava. Basically it’s configuration says that you should use Java 6 to compile it. The error is annoying, but you should be fine even if you get it. I do too. Eventually SciJava will migrate to Java 8.

Regards,
Richard

2 Likes

Thanks for the clarification Richard