Save as nrrd in macro mode does not work

Hello everyone,
Using FIJI, I am trying to save my time series in nrrd format, which will then be used in elastix for registration. While saving images manually in nrrd format works perfectly fine, it does not work in the little macro I wrote. Specifically, I have trouble in the following command,

run("Nrrd ...", "save="+target_dir+"/"+saveFileName+".nrrd");

In the macro commands site, I see that under saveas there is no option for nrrd. Is there a work around?

Thanks a lot for the help
Best regards
Sundar

Hi @sundar,

run("Nrrd ... ", "nrrd=/home/john/foo.nrrd");
works for me.

John

1 Like

Thanks so much @bogovicj
After seeing your code, I realized I was missing a space after the three dots and that solved the problem.
I should remember to copy-paste directly from ‘Record macro’ next time, instead of typing this manually.

Best
Sundar

1 Like