Running CellProfiler on a remote machine



I’ve installed cellprofiler on a cluster and would like to run it remotely. I can either sit at the cluster or login with apple remote desktop and run the program by clicking the icon. I can also run other X11 applications remotely (for example xcalc).

I log into the cluster using:

ssh -X -l charliew

and try to run the program using:

charliew$ ./CellProfiler.command &

several errors appear and I’m not sure how to fix them. Can you help? An example session is:

ccr-104:~ charlie$ ssh -X -l charliew
Last login: Wed Mar 1 13:06:59 2006 from
Welcome to Darwin!
luria:~ charliew$ cd /Applications/MAC_CellProfilerv1/
luria:/Applications/MAC_CellProfilerv1 charliew$ ./CellProfiler.command &
[1] 25142
luria:/Applications/MAC_CellProfilerv1 charliew$ kCGErrorRangeCheck : Window Server communications from outside of session allowed for root and console user only
INIT_Processeses(), could not establish the default connection to the WindowServer…/CellProfiler.command: line 1: 25143 Abort trap open /Applications/Utilities/
Warning: Unable to open display :0.0, MATLAB is starting without a display.
You will not be able to display graphics on the screen.
MATLAB is starting without a display, using internal event queue.
You will not be able to display graphics on the screen.

Warning: No window system found. Java option ‘MWT’ ignored


Hi Charlie,

What exactly are you trying to do, run cluster jobs with CellProfiler or just use CellProfiler remotely from another computer?

If you are trying to run cluster jobs, you currently need to have the MatLab version of CellProfiler. We have a compiled version working, but the infrastructure is not fully set up and tested therefore we have not released it as of yet. Also, it would have to be compiled specifically for your clusters matlab/gcc version.

If you are simply trying to run CellProfiler remotely, then you may want to edit the CellProfiler.command file. It contains some setup information prior to running the program. One of these settings includes “export DISPLAY=”:0.0"" which seems to be what is causing your errors. I am not sure how X windows decides what remote computers should use for display, so try logging into X windows and type “echo $DISPLAY”. Try entering that value into CellProfiler.command instead of :0.0.

Let me know if that works.



Hi Mike,
At this point, I’m just trying to run CellProfiler from a remote computer.

I tried modifing the

export DISPLAY=

line of CellProfiler.command but still get the same error. I can use Apple Remote Desktop to get around this.

Regarding taking advantage of cluster computing… I’m very interested in learning about that. I can get matlab for the cluster if need be but if you already have a compiled version… that could be great.

thansk a lot



Hi Charlie,

I would probably have to be present to figure out why you are having problems running CellProfiler remotely.

I still have some work on the compiled version of the cluster CellProfiler but it should not be too difficult. This will be a good test for us and will allow us to officially release it once it is done. I will be in touch to help you set this up.