ROI and Spinnaker

Hello - I have issues with ROI and the Spinnaker device adapter for FLIR/Point Grey cameras.
I run MM2 2.0.0-gamma1 20210105.

Setting up an ROI is unstable, for some specific ROI sizes, it crashes when I press “snap”.
For instance, in Mode1 (binning 2x2), this works:

mmc.setROI(406,238,936,936);

But this one does not work:

mmc.setROI(406,238,934,936);

I guess it’s related to restrictions about the ROI size (in a previous version of MM, the error message was saying the ROI size was not divisible by four - I cannot reproduce this error message though). The problem is when the ROI is drawn manually, since it’s very hard to be accurate if a precise size must be set.

Here is the log (final lines between ROI setting and crash).

2021-01-08T18:48:42.737438 tid10296 [dbg,Core] Will set ROI of current camera to (left = 406, top = 238, width = 934, height = 936)
2021-01-08T18:48:42.737438 tid10296 [dbg,Core] Did set ROI of current camera to (left = 406, top = 238, width = 934, height = 936)
2021-01-08T18:48:45.626824 tid4004 [dbg,Core] Will update system state cache
2021-01-08T18:48:45.626824 tid4004 [IFO,Core] Did update system state cache
2021-01-08T18:48:45.626824 tid4004 [IFO,App] Updating GUI; config pad = true; from cache = false
2021-01-08T18:48:45.626824 tid4004 [dbg,Core] Will update system state cache
2021-01-08T18:48:45.642316 tid4004 [IFO,Core] Did update system state cache
2021-01-08T18:48:45.642316 tid4004 [IFO,App] Rebuilding config group table
2021-01-08T18:48:45.642316 tid4004 [IFO,App] Finished rebuilding config group table
2021-01-08T18:48:45.642316 tid4004 [IFO,App] Finished updating GUI
2021-01-08T18:48:45.642316 tid4004 [dbg,App] [UI] JButton "Refresh" clicked in MainFrame.
2021-01-08T18:48:49.149931 tid4004 [dbg,Core] Will snap image from current camera
2021-01-08T18:48:49.290559 tid4004 [dbg,Core] Did snap image from current camera

Thanks for your help.
Max