Release of OMERO 5.5.1

Dear all,

Today we are releasing OMERO 5.5.1, a full production-ready release of OMERO.

This bug fix release focuses on installation issues that were seen with 5.5.0 and also upgrades the version of Bio-Formats which OMERO uses to 6.1.1.

This version does not require a database upgrade.

  • OMERO.web:
    • Allow the customization of the web logo
    • Allow overriding server configuration
    • Dynamically look up client download links
    • Fix description in new Project, Dataset etc.
    • Fix layout of the user account form
  • Java gateway:
    • New methods added to allow change group of objects
    • New methods added to load objects (datasets, etc.) by name
    • New methods added to get original and repository paths of images
    • Minor fixes in createDataset and getPixelSize methods
  • Import:
    • Add import target support for creating Projects
  • Scripts:
    • Enable annotating Projects and Datasets with the Populate Metadata script
  • OMERO.server:
    • Fix SSL cipher issue to allow Insight to be used from Fedora 30
    • Fix issue with loading Hibernate’s DTD when offline
    • Properly close OMERO.tables which kept sessions alive

Note : Due to the stricter closing of OMERO.tables, it may be necessary to update plugins like omero-metadata which previously were leaking files.

The software is available at https://downloads.openmicroscopy.org/omero/5.5.1. Clients are no longer available from that location since they will be released more frequently than the server.

OMERO.insight is now available at https://github.com/ome/omero-insight/releases/tag/v5.5.3 with the following changes:

  • Fix SSL cipher issue to allow Insight to be used from Fedora 30
  • Fix stack overflow exception
  • Bump to omero-gateway-java 5.5.3

Official Docker images are available on Docker Hub:

The OME team

2 Likes

A couple things I noticed:

  1. looks like using with zero-ice greater than version 3.6.4 is not supported. I tried zero-ice 3.7.2 and the cmake step failed not finding Ice_SLICE_DIR.

  2. how do I downgrade to setuptools 33.1.1? I tried ‘sudo pip install setuptools==33.1.1’ but my Fedora distro doesn’t like that. I can give more details, but even better would be supporting modern setuptools

so i’m still using 5.4.6 for now
Oh, and do we know if the ’ LINK : fatal error LNK1189: library limit of 65535 objects exceeded ’ problem on Windows is fixed yet?

Correct, Ice 3.7 is not supported and will not be supported; over time we plan to migrate away from Ice.

We don’t expect that there is yet any improvement in the C++ situation on Windows. Unfortunately for some time the core OME team has had very little capacity for maintaining OMERO’s C++ bindings on Windows.

Which version of Fedora are you using? Is there a clear CentOS release to which it corresponds? The platforms and versions described on https://docs.openmicroscopy.org/latest/omero5.5/sysadmins/version-requirements.html tend to get the surest testing.

I’m using Fedora29.
But let’s not pursue this any farther. What I really need is a working Windows version. v5.4.6 is working fine for linux and osx.

One minor suggestion in the buildsystem (perhaps in build.py) is to pre-detect if settuptools version is supported and exit with a nice help message if not.

thanks for your reply and help.
-Allen

I’ve created an issue: https://github.com/openmicroscopy/openmicroscopy/issues/6084

It’s best not to modify system packages using pip as it may break other components of your system. It’s safer to create a virtualenv.

3 posts were split to a new topic: OMERO 5.5.1: Problems with Ice 3.6 vs 3.7