Relate then classify objects help

I’m trying to count the number of nuclei (dapi) stained positive for another marker. I followed the tutorial and identified both primary objects and then used relateobjects to find the children (marker) of each nucleus (parent). Then I used classifyobjects. But this is where the program keeps saying there is an error. I put single measurement, “nuclei” as the object to be classified and “children” as the category. But it keeps saying “parent_object_number has an unavailable measurement category”.

Why do i keep getting that error? I can’t even run that step of the project.

Hi,
Could you post your project file (and perhaps a sample image) so we can take a look?
-Mark

Sorry for delayed response and thank you for your help! We have been busy moving our lab.

Anyway, here are the links to the files

dropbox.com/s/ppa480903o9ox … pproj?dl=0

dropbox.com/s/xtpq1prh038r88x/ch01.tif?dl=0

dropbox.com/s/ombkiqazb70476x/ch00.tif?dl=0

Thanks!

Hi,

This was due to a bug (this one, which has since been fixed but not yet released) where unless you explicity select your desired choice from the drop-down box, the module won’t recognize it. If you pick “Children” from the Category drop-down in ClassifyObjects, the error goes away.

Regards,
-Mark

Thanks! But I actually still get an error when “children” is selected. Any idea when the update will be released?

If you then pick the Measurement from the drop-down under “Children” (rather than leaving it at whatever is selected by default), what happens then?
-Mark

I don’t have the option to select “measurement” unfortunately.

Hmmm, I’m a bit confused. So if you remove the ClassifyObjects module and then add it back in (to start fresh) and then do the following:

  • For “Select the object to be classified”, select “nuclei”
  • For “Select the measurement to classify by”, under “Category” select “Children” (don’t just accept the default)
  • A “Measurement” setting should appear, for which you select “survivin_Count” (again, don’t just accept the default)

Then it doens’t work?
-Mark