Redhat6 with CP2

Dear CellProfiler users,installers,coders etc…

I recently tried to install CP2 in linux, using RedHat 6.4 ws, I managed to battle through until actually trying to start CP2, I created an alias for ‘python /usr/CellProfiler/src/Cellprofiler.py’… the output from start up is quite long, I might have an issue with Maven, but the start-up script stops, just after showing the small graphic window with CellProfiler. The end of the script output is as follows…

line 285, in get_cellprofiler_jars
additional_args = “-Dexpression=project.build.finalName”])
File “/usr/CellProfiler/src/CellProfiler/external_dependencies.py”, line 231, in run_maven
return subprocess.check_output(args, cwd = pom_path, env=env)
AttributeError: ‘module’ object has no attribute 'check_output’
Failed to stop Ilastik

I do not understand if this is a error associated with maven, python or a mistake I made when following the set-up instructions. If anyone else has experienced this error, I would be greatful for any helpful feedback. Thank you for your support and advice.

Kind regards, James

Hi James,

Not sure, but perhaps this will help? (From this thread comment)

Let us know if this helps.
David

Hi David,

I added PYTHONPATH to my bashrc but ILASTIK module is still missing/not found etc… I have tried to install ILASTIK, that did not work… I will persevere with trying to get CP2 working with RHEL6. There may well be issues with Java and Maven compatibility which I am investigating now.

Thank you for your help, I will keep you informed as to whether I succeed, or what progress I eventually make.

Best regards, James

Hi James,

When you say

[quote]I added PYTHONPATH to my bashrc…
[/quote]

I believe the advice was to add the ilastik path to your PYTHONPATH variable, rather than adding PYTHONPATH to your bashrc. Is that what you meant?

In the meantime, I am asking our Linux gurus if they have any further advice.

David

Hi James,

One of us here is working on RPMs for Redhat now. He says the ETA for those is perhaps a week.
I’ll try to remember to post here, but also check our Github wiki page for Linux installations.

Hope that helps,
David

Dear David,

RPM installation would be a less painful tool and easier to manage. I will certainly keep a watch of the github wiki pages. I tried to install Ilastik, but the graphical interface of CellProfiler still crashed with a module failure. Issues seem to relate to java versions, Numpy (Python versions) and probably a Maven problem too.

Thank you for your feedback. I will keep at this until I find a solution or the RPM becomes available.

Kindest regards, James Robinson
Bioinformatician, Materiomics BV, Enschede, NL.

Dear David,

I installed the yum repo for Centos6, installing CP2.1 linux beta seems to work okay. I particularly like its parallel performance.
baseurl=http://www.cellprofiler.org/linux/centos6/

I would like to be able to better translate CP2 pipeline CP files into ‘MAT’ files for CP1 running with matlab on a cluster, it is a little fiddly. Perhaps CP2.1 on the linux cluster is the way ahead? Please extend my thanks to the individual or team that released the yum repo for Centos6.

Kind regards, James

Hi James,
Good to hear that yum is working for you for 2.1!

For others reading this, instructions are here. Note that this is still in Beta:
cellprofiler.org/linux.shtml

As for cluster processing, I’d say that CP 2.1 is definitely the way ahead. CP used to run as Matlab of course, but installing Matlab on every node and getting the versions striaght was a hassle, and python seemed the way to go. We are not supporting CP1.0 (Matlab) any more, other than out of the goodness of ours hearts :smile: .

Hope this helps,
David

We also keep having the same problem with SUSE. CP keeps crashing in the GUI mode when you click on one of the modules in the pipeline apart from some random crashes which are not too infrequent.

Parthiv, are the errors happening with the rpm-installed version from here? A number of changes went into this installer and we hope the versions are all compatible now. I believe on SUSE you can use the ‘rpm’ command rather than yum, though we don’t have SUSE to test on.
-David

Hi David,
We installed the new version. The following is the error we get.

[quote]Plugin directory doesn’t point to valid folder: /mnt/mbi/home/parthiv/plugins
Pipeline saved with CellProfiler version 20131205152921
Pipeline saved with CellProfiler version 20131205152921
Pipeline saved with CellProfiler version 20131205152921
Pipeline saved with CellProfiler version 20131205152921
Version: 2013-12-05T15:29:21 2.1.0.Beta_2a.linux / 20131205152921
Pipeline saved with CellProfiler version 20131205152921
Pipeline saved with CellProfiler version 20131205152921
Pipeline saved with CellProfiler version 20131205152921

A fatal error has been detected by the Java Runtime Environment:

SIGSEGV (0xb) at pc=0x0000000005403bd0, pid=22272, tid=140199988066048

JRE version: 7.0_21-b11

Java VM: Java HotSpot™ 64-Bit Server VM (23.21-b01 mixed mode linux-amd64 compressed oops)

Problematic frame:

C 0x0000000005403bd0

Failed to write core dump. Core dumps have been disabled. To enable core dumping, try “ulimit -c unlimited” before starting Java again

An error report file with more information is saved as:

/mnt/mbi/home/hemant/hs_err_pid22272.log

If you would like to submit a bug report, please visit:

bugreport.sun.com/bugreport/crash.jsp

The crash happened outside the Java Virtual Machine in native code.

See problematic frame for where to report the bug.

/opt/UserApps/bin/cellprofiler: line 19: 22272 Aborted $prefix/bin/python prefix/src/CellProfiler/CellProfiler.py "@"[/quote]

The CP script is as follows

[code]#!/bin/sh

Wrapper script used to start CellProfiler on Linux.

prefix=/opt/UserApps/cellprofiler2.1

export LD_LIBRARY_PATH=$prefix/lib:$prefix/jdk/jre/lib/amd64/server:/usr/lib64/atlas:$prefix/lib/wxPython-2.8.11.0-gtk2-unicode/lib
export LIBRARY_PATH=$prefix/lib:$prefix/jdk/jre/lib/amd64/server:/usr/lib64/atlas:$prefix/lib/wxPython-2.8.11.0-gtk2-unicode/lib
export PATH=$prefix/bin:$prefix/jdk/bin:$PATH
export PYTHONPATH=$prefix
export PYTHONHOME=$prefix
export PYTHONUSERBASE=$prefix/lib/python2.7
#export JAVA_BINDIR=/usr/lib64/jvm/java/bin
#export JAVA_HOME=/usr/lib64/jvm/java-1.7.0-openjdk-1.7.0
#export JAVA_ROOT=/usr/lib64/jvm/java-1.7.0-openjdk-1.7.0
export JAVA_HOME=$prefix/jdk

#cd $prefix/src/CellProfiler
$prefix/bin/python prefix/src/CellProfiler/CellProfiler.py "@[/code]

Hi Parthiv,

When do you get this error? Upon startup? Did you use the instructions here to install? cellprofiler.org/linux.shtml

David