QuPath unable to open .SCN files?

Hi all,

I’m trying to open my .SCN files in QuPath but I keep getting an error saying it is unable to import it. Doesn’t QuPath support .SCN formats? I’ve had no problem opening .svs or .tif images in the same directory.

image

QuPath can open SCN files. However, you need to have BioFormats installed and from Milestone 3 onwards scn files can only be opened within a project.
See this thread/post:

1 Like

I’ve installed BioFormats and tried opening the .SCN file in my project folder and still got the same error. Except this time it loaded the macro image accompanied with the file. The macro image is simply just the thumbnail of the whole slide image :frowning:

Short update! I’ve updated to m3 as well and tried opening my .SCN file in the folder, but nothing opens and there isn’t even an error window.

Can you share the original image file?

It seems like I can’t share .SCN files in this forum. I’ve shared the file here for download:

https://drive.google.com/drive/folders/1jq9LMLFiCpaHF15LOfLG4Nw8F07v5nji?usp=sharing

Really appreciate the help thanks

In v0.2.0-m4 (the most recent download - I don’t have m3 installed any more) it works fine for me on Windows 10.

As @MartinH says, you need to create a project first (e.g. by draging an empty folder onto QuPath). Then I can drag the .scn file onto QuPath, the dialog pops up and I accept the defaults to add the image.

The result is that I can see the macro/overview image and two other whole slide images (which look similar) and I can switch between them,.

Updating to m4 seemed to fix the problem. I made sure to create the project and drag the files for both versions. I’m not quite sure why but it works! Thank you for your help!

1 Like

Good! I don’t recall changing something in this regard for m4, but it’s possible that I did. It also includes a more up-to-date Bio-Formats, which may help.

Glad it’s resolved somehow in any case!