QuPath Stardist Tensorflow

Having previously built Qupath 0.2.3 to use Stardist, I have now tried to apply usign teh dsb2018_heavy_augment and it is now not working - with the same error message as previously.

Although the build was successful, I cannot see Tensorflow in the extensions list.

  • Upload an original image file here directly or share via a link to a file-sharing site (such as Dropbox) – (make sure however that you are allowed to share the image data publicly under the conditions of this forum).
  • Share a minimal working example of your macro code.

Background

  • What is the image about? Provide some background and/or a description of the image. Try to avoid field-specific “jargon”.

Analysis goals

  • What information are you interested in getting from this image?

Challenges

  • What stops you from proceeding?
  • What have you tried already?
  • Have you found any related forum topics? If so, cross-link them.
  • What software packages and/or plugins have you tried?

Hi.

Could you link the post where you mention “as previously” ?

What os are you building QuPath on top of?

If the build was successful and you still do not see it, it it possible that you are not running the QuPath executable from within your build/dist/Qupath… Folder?

Apologies - here it is :slight_smile:

I am using Mac Catalina. When I run ./build/dist/QuPath-0.2.3.app it does come up with ‘permission denied: ./build/dist/QuPath-0.2.3.app’…

So it seems it hasn’t even managed to build the latest version and you might still be running the old one.

One solution on our olde friend StackOverflow is to change the permissions of the project

I suggest you try changing the file permissions as the post above suggests and then trying again the
gradlew clean build createPackage -Ptensorflow-cpu=true command and letting us know if that worked for you.

Best

Oli

1 Like

Hi Oli,
Thank you for that however it is still not working and has the same error message, despite the build being successful. And also Tensorflow is still not in the installed extensions list.
So, just to recap I have:
-changed permissions on the project folder
-run gradlew clean build…

Kylie

and if I run ./build/dist/QuPath-0.2.3.app it still says permission denied.
I am running it within zsh - not sure if that makes a difference?

Update: as per the previous post I have then closed QuPath, run ‘open ./build/dist/QuPath-0.2.3.app’ then reopened Qupath and the project and run Stardist again.
It now works! Thank you for your help :slight_smile:

1 Like

Ok great. So QuPath was running and thus the build could not go through. Thanks a lot for telling us the cause!

All the best

1 Like