QuPath: red channel does not display or export at high magnification

Hello
Using QuPath-0.2.0 for fluorescence images (3 colours), the red channel disappears when I zoom in. If I try to export to ImageJ at high resolution, it’s also lost.
Does anyone have any thoughts?
Thanks

Hi @chrisdias2, I’d need a lot more information, e.g.

  • What file format is the image?
  • Do you see any errors under View → Show log?
  • Is it an RGB image or a multichannel image of some other kind?
  • Can you view the same regions in any other software?

My guess is that there is an issue with the file that means parts can be read, but I have never seen this exact issue before.

Also, which milestone of v0.2.0?

Closest I recall is this:

Thanks Pete.
I reinstalled QuPath (same version, 0.2.0-m9) and it seems to have resolved, though concerned it may happen again. In answer to your questions:

The format is .czi
Lost the log as reinstalled before I saw your message
Fluorescence multichannel
I haven’t been able to open in another software because they are very large (.czi files from 1.3 to 2.6 Gb) - hence trying to use QuPath to export subsets of the image.

Thanks

Hi @chrisdias2, I wouldn’t normally expect reinstalling QuPath to help much - usually restarting the application is enough, or resetting the preferences if things go more badly wrong. But glad to read it seems to be working now.

Since the file formats is also .czi, it sounds very likely to be the issue linked to be @Research_Associate. I understand this bug has been fixed in Bio-Formats 6.4.0, which will be included with the next release of QuPath (v0.2.0-m9 uses 6.3.1).

Yes, it seems to be the same problem @Research_Associate mentioned.
I may have spoken too soon though. Now with a 4 channel image the same is happening with the 4th channel.
The log indicates:
WARN: Could not decompress block; some pixels may be 0

1 Like