QuPath groovy 3.0.6 issue setting up in IntelliJ

Hi all

I am following the tutorial here to set up QuPath scripting on IntelliJ:
https://github.com/qupath/qupath/wiki/Advanced-scripting-with-IntelliJ. After setting up as instructed, upon running import qupath.lib.scripting.QPI received an error “Caused by: groovy.lang.GroovyRuntimeException: Conflicting module versions. Module [groovy-jsr223 is loaded in version 3.0.6 and you are trying to load version 3.0.3”

I installed groovy 3.0.6 and wondering if QuPath strictly requires 3.0.3 to work?

It shouldn’t – I don’t think I’ve ever bothered to ensure my Groovy versions match, and haven’t seen this error. The instructions are a bit out-of-date (written for v0.1.2) so might require some adapting.

Hi Pete, thank you for your reply. I have noticed one of the QuPath dependencies tries to invoke “groovy3.0.3.jar, groovy-jsr223-3.0.3.jar and groovy-xml-3.0.3.jar”. Do you think this may be the culprit?How can I exclude them?

Sorry, I don’t have a solution. I would guess something under File → Project Structure… may help, or else try installing Groovy 3.0.3.

I have Groovy 3.0.7 installed (as groovy library) and all the .Jar files from QuPath App dir added as module dependencies, no issues in intelliJ so far on Windows 10.