Qupath: clipped max values

Hello everyone,

I am using Qupath to analyze some whole slide images acquired with an Olympus VS120 (Hamamatsu Orca2 camera, 16-bit images in fluorescence mode, file format .vsi). Is there any news on a work around to change the max value in the histogram for a given channel? This issue was brought up on Github a while back too but the solutions proposed didn’t work for me https://github.com/qupath/qupath/issues/352

Thanks!

Melina

What version of QuPath are you using, and what is the behavior when you try double clicking?

Hi!

I am using v 0.2.0-m2. When I click on the max display label as suggested and enter a higher number than the clipped max value, the value simply stays the same.

M.

The display value should stay the same, but the actual value as shown in the Viewer area should change… I think. M2 was a while ago though, and I moved on from it as quickly as possible due to project compatibility and network sharing issues. Unfortunately, if it doesn’t work in M2, it isn’t likely to be fixed in M2 since QuPath is on M6 now, and it would be really difficult to keep up with all of the previous versions. I would generally recommend using the script, which should always work and has the added benefit of keeping the display settings consistent between images. Which they generally should be for comparison purposes.

Yes I meant the range stays the same as well as the actual max value. But i’ll try m6 or the script now and get back to you.

Thanks!

M.

1 Like

Hello again,

So I tried v m6. Same issue. The display range is clipped at the max value instead of displaying all 0 to 65535 levels. Impossible to change it just by setting the value manually. As for the scripting method, forgive my ignorance, I am not a programmer and I rely heavily on the script editor. Could you point me to an example script with commands for the display range?

Having the possibility to play with the display beyond the max value is truly essential to the workflow we are trying to develop. We are imaging post-mortem tissue probed with several RNAScope tags. Qupath is the only open source software that can handle these types of image sets well.

Thanks again!

M.

The example script is in the link you provided in the first post, and would still be the recommended method.

If you want to set the visual thresholds manually, I just verified that typing in the value works. Demo below.


I’m working with the standard LuCa file linked in various other places, but it is a float 32 image with an even higher number of display levels than you describe (2,147,483,647). The default max display level for this image and channel, though, is 28.1.
Maxing that out looks like this:

Double clicking on the max value and setting it to something really large:

Results in my red channel essentially going away completely.

The Max display number itself does not change and is not supposed to change.
Double clicking on the 55.0 again show what the max number actually is:

It may not be the behavior that you expect, but if the display isn’t changing, there is something else wrong. In M6 (and in most previous versions) this should work. The main change in the Milestones is the “Keep settings” checkbox that remembers the settings you have applied when you go to a new image with the same number of channels and bit depth.

Ok. It worked! for some reason when I had a vsi opened on its own it would not change the display but when I’m working on a project it works perfectly. Thank you for you precious help. I am a huge fan of Qupath and look forward to develop workflows for my users on it!
Are there any plans to improve the histogram to reflect the full 16 bit range in the future?

Best,

Melina

1 Like

I don’t believe so based on Pete’s response in your original link above. That may change if the usage of 16/32bit images becomes much more prevalent, but we will have to see.

I also hadn’t realized that was something that was project dependent, so thank you for pointing that out.