Problems with windows vista

cellprofiler

#1

Hi,

I’ve been using Cell profiler with Win XP for quite some time without any problems. Now I need to run it under Windows Vista (32 bit). I downloaded and installed the appropriate MCR, but when starting Cell profiler the error ‘‘Undefined function or variable ‘Cell profiler’ MATLAB:Undefinedfunction’’ appears. At the first start, Cell profiler initiated extraction of the .ctf file but then the window closed without starting the program.

Is this a common problem with windows vista?

DS


#2

Hello,
I just tried downloading CellProfiler for Vista32. It worked fine for me. When you double-clicked on CellProfiler.exe, did it ask you to extract the files? Then, just double-click on CellProfiler.exe, again, and it will unpack the CTF and start.

If you experienced anything that seemed different/strange. Please let me know and I will try to troubleshoot the issue.

thanks,
Martha


#3

Hi Martha,

When I double-klick on CellProfiler.exe it automatically starts extracting the ctf file but then the window closes immediately and when I then double-klick on the .exe again, it shows the error message mentioned above. First I thought it is due to a common vista error (APPCRASH) but I fixed this problem and CellProfiler is still not running.

best wishes

David


#4

We’re guessing that it cannot find the CTF file when you click on CellProfiler.exe. Are the files in the same directory?


#5

Yes they are.

Another problem is, that Cell Profiler obviously does not try to extract the ctf file a second time after the first extraction failed. I have uninstall and deleted all CellProfiler files, and repeated the whole installation procedure several times but it is not working.

David


#6

Cell Profiler starts extracting the ctf file but after a few seconds, the window suddenly closes without any further reaction.


#7

Is the disk possibly full? We haven’t seen this behavior before. Without knowing why it’s failing (or if any error message comes up when it does), we probably can only guess what’s going on.


#8

No, about 40 Gb of disk space is free.

Is it possible to manually extract the ctf file?


#9

Ok, it was a problem with the safety settings of windows vista. It is running now. Anyway, thanks for your support.

best wishes

David


#10

Thanks for letting us know! If anyone else has this issue, we will have them check their safety settings.
~martha