Problems with software changing fluorescent channels

Hello everyone,
We are trying to image cells using multiple fluorescent channels. Currently we can change the filters on the microscope by hand but when we tell the program to take a photo of multiple channels it does not change the filter, so on the acquired image the same picture is being imaged for all our selected channels. Are we missing pressing a button or is there a configuration error? In the future we would like to be able to image 3 fluorescent channels and brightfield at the same time, is this possible?
Thank you, Alicia

Hi Alicia/@aseustes,

Automated 3 fluorescent and 1 brightfield channel is certainly possible in Micro-Manager. That is more or less what it was designed to do.
The Micro-Manager website (https://micro-manager.org) is full with information on how to configure and use the software. Highly abbreviated: you will need to define “Configuration presets” for your fluorescent and brightfield channels. You should be able to select a specific channel by clicking on the setting, and choosing the new setting from the drop-down box. When you configure this (start with the “Group +” button), include the “Core-Shutter” property to switch between brightfield and fluorescent shutter.

Once you have that set-up correctly, click on “Multi-D Acq”, select the “channel group” that has your presets, and you are ready to go.

I you still have questions after reading the documentation Nico posted, why don’t you send you config file and we can see if someone can offer pointers there.

Sam

Thank you for the replies. I’m still having some problems getting this to work. I can add a new group and have put on the core shutter but I am still having problems with the program switching the shutters. I have added our configuration below.
Alicia

Generated by Configurator on Fri Sep 30 16:48:48 PDT 2011

Reset

Property,Core,Initialize,0

Devices

Device,HamamatsuHam_DCAM,HamamatsuHam,HamamatsuHam_DCAM
Device,DHub,DemoCamera,DHub
Device,Camera,DemoCamera,DCam
Device,Dichroic,DemoCamera,DWheel
Device,Emission,DemoCamera,DWheel
Device,Excitation,DemoCamera,DWheel
Device,Objective,DemoCamera,DObjective
Device,Z,DemoCamera,DStage
Device,Path,DemoCamera,DLightPath
Device,XY,DemoCamera,DXYStage
Device,Shutter,DemoCamera,DShutter
Device,Autofocus,DemoCamera,DAutoFocus

Pre-init settings for devices

Pre-init settings for COM ports

Hub (parent) references

Initialize

Property,Core,Initialize,1

Delays

Focus directions

Roles

Property,Core,Camera,HamamatsuHam_DCAM
Property,Core,AutoShutter,1

Camera-synchronized devices

Labels

Dichroic

Label,Dichroic,9,State-9
Label,Dichroic,8,State-8
Label,Dichroic,7,State-7
Label,Dichroic,6,State-6
Label,Dichroic,5,State-5
Label,Dichroic,4,State-4
Label,Dichroic,3,State-3
Label,Dichroic,2,Q585LP
Label,Dichroic,1,Q505LP
Label,Dichroic,0,400DCLP

Emission

Label,Emission,9,State-9
Label,Emission,8,State-8
Label,Emission,7,State-7
Label,Emission,6,State-6
Label,Emission,5,State-5
Label,Emission,4,State-4
Label,Emission,3,Chroma-HQ700
Label,Emission,2,Chroma-HQ535
Label,Emission,1,Chroma-D460
Label,Emission,0,Chroma-HQ620

Excitation

Label,Excitation,9,State-9
Label,Excitation,8,State-8
Label,Excitation,7,State-7
Label,Excitation,6,State-6
Label,Excitation,5,State-5
Label,Excitation,4,State-4
Label,Excitation,3,Chroma-HQ620
Label,Excitation,2,Chroma-HQ570
Label,Excitation,1,Chroma-HQ480
Label,Excitation,0,Chroma-D360

Objective

Label,Objective,5,Objective-5
Label,Objective,4,Objective-4
Label,Objective,3,Nikon 20X Plan Fluor ELWD
Label,Objective,2,Objective-2
Label,Objective,1,Nikon 10X S Fluor
Label,Objective,0,Nikon 40X Plan Flueor ELWD

Path

Label,Path,2,State-2
Label,Path,1,State-1
Label,Path,0,State-0

Configuration presets

Group: Camera

Preset: MedRes

ConfigGroup,Camera,MedRes,Camera,Binning,2
ConfigGroup,Camera,MedRes,Camera,BitDepth,10

Preset: HighRes

ConfigGroup,Camera,HighRes,Camera,Binning,1
ConfigGroup,Camera,HighRes,Camera,BitDepth,12

Preset: LowRes

ConfigGroup,Camera,LowRes,Camera,Binning,4
ConfigGroup,Camera,LowRes,Camera,BitDepth,8

Group: Objective

Preset: 20X

ConfigGroup,Objective,20X,Objective,State,3

Preset: 40X

ConfigGroup,Objective,40X,Objective,State,0

Preset: 10X

ConfigGroup,Objective,10X,Objective,State,1

Group: Channel

Preset: FITC

ConfigGroup,Channel,FITC,Dichroic,Label,Q505LP
ConfigGroup,Channel,FITC,Emission,Label,Chroma-HQ535
ConfigGroup,Channel,FITC,Excitation,Label,Chroma-HQ480

Preset: Rhodamine

ConfigGroup,Channel,Rhodamine,Dichroic,Label,Q585LP
ConfigGroup,Channel,Rhodamine,Emission,Label,Chroma-HQ700
ConfigGroup,Channel,Rhodamine,Excitation,Label,Chroma-HQ570

Preset: DAPI

ConfigGroup,Channel,DAPI,Dichroic,Label,400DCLP
ConfigGroup,Channel,DAPI,Emission,Label,Chroma-HQ620
ConfigGroup,Channel,DAPI,Excitation,Label,Chroma-D360

Preset: Cy5

ConfigGroup,Channel,Cy5,Dichroic,Label,400DCLP
ConfigGroup,Channel,Cy5,Emission,Label,Chroma-HQ700
ConfigGroup,Channel,Cy5,Excitation,Label,Chroma-HQ570

Group: System

Preset: Startup

ConfigGroup,System,Startup,Camera,BitDepth,16
ConfigGroup,System,Startup,Camera,ScanMode,1
ConfigGroup,System,Startup,Objective,Label,Nikon 10X S Fluor
ConfigGroup,System,Startup,Camera,Binning,1

Group: LightPath

Preset: Camera-left

ConfigGroup,LightPath,Camera-left,Path,State,1

Preset: Eyepiece

ConfigGroup,LightPath,Eyepiece,Path,State,0

Preset: Camera-right

ConfigGroup,LightPath,Camera-right,Path,State,2

PixelSize settings

Resolution preset: Res20x

ConfigPixelSize,Res20x,Objective,Label,Nikon 20X Plan Fluor ELWD
PixelSize_um,Res20x,0.5

Resolution preset: Res40x

ConfigPixelSize,Res40x,Objective,Label,Nikon 40X Plan Flueor ELWD
PixelSize_um,Res40x,0.25

Resolution preset: Res10x

ConfigPixelSize,Res10x,Objective,Label,Nikon 10X S Fluor
PixelSize_um,Res10x,1.0

The configuration you posted is the “demo” configuration with an added Hamamatsu camera. The “demo”/“virtual” equipment will not do anything (other than simulate hardware), so do not expect anything to happen. Start with a new configuration file with the Hamamatsu camera and your other equipment. Once you define your “channel” group, add the “Core”-“Shutter” property. That property lets you switch the “active” shutter.