Problems uploading timelapse - 4 channels


I am having some trouble uploading my overweekend time-lapse. I am working with Cell profiler 3.1.9 on windows 10.

At images I provide a tif file consisting of four channels with each 555 pictures. Next, I select them by header in MetaData. There all files split up in the channels and at timepoint perfectly.
However, when I want to select them by C = channel and T = timepoint in NamesAndTypes I get the following error:

I do not understand why and how I should change this. I have read the help sections mutliple times but I don’t understand the problem. After this I would want to use the pipeline Object Tracking.


Hello Mirjam,

Could you upload your pipeline and a couple of images?
A couple of things I can think of:

  1. If have any other identifier except the FileLocation in your images (Plate name, Experiment, etc.) try using those instead of the FileLocation.
  2. Make sure in Metadata, you first click “Update metadata” (right below your extraction method) and then “Update” button on the generated table.
  3. If you hover over the red X by the module, it can give you some info about what is missing or need to be changed.

If you could upload your pipeline and images, we can have a closer look.

Hi @MirjamV,

In addition to the above, I’d also suggest removing the “Image Is Stack frame” filter from your NamesAndTypes groups. I’m not sure what function this is serving but it may be interfering with the matching sequence.

@DStirling @Nasim I tried what you mentioned but it did not help. Luckily, I could get a spot for coming friday’s office hours!
Nonetheless, thanks for you help!


Thanks for the meeting we had! Hopefully, you can have a closer look at my files and the pipeline. I already looked into the settings of the pipeline before.

Test_Pos1.cpproj (114.6 KB)


I don’t have permission to access your images, but it seems your Grouping (Group module) might be the issue.
Try it first without grouping (pipeline to read the images attached).
Test_Pos1_Test.cppipe (9.1 KB)


Thank you very much! It is working now :slight_smile: