Problems installing/running on OS 10.4.11

cellprofiler

#1

I could use some advice on getting CellProfiler to run properly on my Mac. After loading X11 from the install DVD I’m now getting the message below. I am working on an intel core 2 duo system running OS 10.4.11. I’ve not located a solution in the PDF manual or on review of the user group posts. Where to next?

MWH

/Applications/CellProfiler/CellProfiler.command; exit
Welcome to Darwin!
111UG-172-18-172-64:~ marchalterman$ /Applications/CellProfiler/CellProfiler.command; exit
name /Applications/CellProfiler/CellProfiler.command
/Applications/CellProfiler/CompiledCP/MCR/v76
/Applications/CellProfiler/CompiledCP/MCR/v76/sys/os/maci:/Applications/CellProfiler/CompiledCP/MCR/v76/bin/maci:/System/Library/Frameworks/JavaVM.framework/JavaVM:/System/Library/Frameworks/JavaEmbedding.framework/JavaEmbedding:/System/Library/Frameworks/JavaVM.framework/Libraries
Fatal error loading library /Applications/CellProfiler/CompiledCP/MCR/v76/bin/maci/libmwmclmcr.dylib Error: dlopen(/Applications/CellProfiler/CompiledCP/MCR/v76/bin/maci/libmwmclmcr.dylib, 9): Library not loaded: /usr/X11R6/lib/libXext.6.dylib
Referenced from: /Applications/CellProfiler/CompiledCP/MCR/v76/bin/maci/libmwhg.dylib
Reason: no suitable image found. Did find:
/usr/X11R6/lib/libXext.6.dylib: mach-o, but wrong architecture
logout
[Process completed]


Mac leopard operating system problems
#2

It looks like CellProfiler is having trouble with X11. Be sure that X11 was actually installed (/Applications/Utilities/X11.app exists). Note that you do not need to run X11 manually, it will load when CellProfiler.command is run. Also make sure that you have at least version 1.1.3 of X11 (once CellProfiler.command is executed, check the X11-> “About X11” output).

Let us know if this helps,
Dave


#3

Dave,

That worked. The DVD contains version 1.1. 1.1.3 downloaded from the Apple website did the trick. Thanks.

MWH


#4

Hi,
I have been repeatedly trying to install CellProfiler on an Intel-based Mac Book Pro running Mac OS X Leopard and I always get the following message:
Last login: Wed Feb 13 23:19:03 on console
/Volumes/CellProfiler_MacI_1.0.4942/CellProfiler.command ; exit;
Macintosh-6:~ carlosfitzsimons$ /Volumes/CellProfiler_MacI_1.0.4942/CellProfiler.command ; exit;
name /Volumes/CellProfiler_MacI_1.0.4942/CellProfiler.command
/Volumes/CellProfiler_MacI_1.0.4942/CompiledCP/MCR/v76
/Volumes/CellProfiler_MacI_1.0.4942/CompiledCP/MCR/v76/sys/os/maci:/Volumes/CellProfiler_MacI_1.0.4942/CompiledCP/MCR/v76/bin/maci:/System/Library/Frameworks/JavaVM.framework/JavaVM:/System/Library/Frameworks/JavaEmbedding.framework/JavaEmbedding:/System/Library/Frameworks/JavaVM.framework/Libraries
Extracting CTF archive. This may take a few seconds, depending on the
size of your application. Please wait…
Failed to create a directory required to extract the CTF file. Directory:
’/Volumes/CellProfiler_MacI_1.0.4942/CompiledCP/CellProfiler_mcr/bin/maci’
System error text: 'Read-only file system’
Code: 30??? &)u? ???/u?
Error opening '/Volumes/CellProfiler_MacI_1.0.4942/CompiledCP/CellProfiler_mcr/bin/maci’
Error initializing CTF Archive

I have followed the instructions given to a previous user with similar problem and yes, X11 is installed and running and I do have the latest version available on Apple’s website…any clue on what to do?
Many thanks,
Carlos


#5

Hello Carlos,

Unfortunately, we are not yet supporting Leopard (regardless of the subject line, this is of course OS X 10.5). I don’t think anyone in the platform has tried compiling on 10.5 yet, but it is on our ToDo list.

In any case, your problem seems to be a permissions error, because it can’t write to ‘/Volumes/…’. Are you sure that you did CellProfiler’s instructions step #3, i.e. “Copy the contents of the DMG file to your computer”?

Dave


#6

Dave,
thanks a lot, that was my mistake. Everything was stored on a temp folder on my desktop and that was the reason why it couldn’t write to /Volumes. The good side of it is that now we know it works under OS 10.5. Ready to go then.
Cheers,
C.


#7

Great! It’s good to hear that you have it working on 10.5. Please let us know if you have any issues, since we’re early in the testing phase.

Cheers,
Dave