Problems in Splitting Image into Different Channels

Hi,
I am facing a rather odd problem in splitting Images in Cellprofiler. When I am using Input module to Load images into the pipeline, the splitting is not taking place but when I use Loadsingle Image module things are working fine.
Since I have huge data I was looking for Batch processing so can’t afford to use Loadsingle Image module.
Additionally, the images that I have are LSM images and I have converted them to Tiff images using Bioformats in ImageJ for CP analysis. (Used ImageJ for Batch conversion of images)
I did more thing, converted LSM image to tiff image using LSM image browser and surprising for this image, both Input module and Loadsingle Image are working.
I am very confused what is happening.
I am attaching the pipeline that I am using and also the images.

Thanks
Ashima




Test.cppipe (9.23 KB)

Hi Ashima,

The exported TIFFs you provided are actually 3-plane tiffs, and moreover, each plane seems to contain the same (redundant) info. I assume you tried to export the tiffs as single-plane grayscale images? FYI, I verified this in FIJI. So it’s not surprising that CellProfiler’s ColorToGray looks like it has the same info in each channel.

Regardless of the above, I would suggest that you not export to TIFFs at all and let CellProfiler handle the extraction from the LSM files directly. CP also uses Bio-Formats, so it should be equivalent to your ImageJ step, and in fact, should save you the trouble (and storage space, etc). Would post one of your LSM files? We can show you how to setup the Input Modules correctly (you need to use Metadata to extract the channel info, and change your NamesAndTypes accordingly).

Best,
David

Hey David,
Many thanks for the reply.
"The exported TIFFs you provided are actually 3-plane tiffs, and moreover, each plane seems to contain the same (redundant) info. I assume you tried to export the tiffs as single-plane grayscale images? FYI, I verified this in FIJI. So it’s not surprising that CellProfiler’s ColorToGray looks like it has the same info in each channel."
I got what you are saying here. But why does CP behaves differently if the mode of loading images is different. I am getting three different channels using ColortoGray when I am using LoadSingleImage module with the same image that I used for Input module.

And here are two LSM files
dropbox.com/sh/u39h82toajrw … MNxwa?dl=0.
Please have a look. (And forum doesn’t allow .lsm to upload acc to me. I got this error.)

Thanks
Regards
Ashima

Hi Ashima,

As for LoadSingleImage, I’m not sure I understand, but it may be that LoadSingleImage assumes that the image is grayscale and so only is loading the first plane of the stacked tiff. In any case, please note that LoadSingleImage should only be used in special cases! This is from the HELP section of LoadSIngleImage:

Thanks for the LSM files (Note you can always zip the files and the forum will accept them, but Dropbox is fine, though may not last for others, if you delete them. We unfortunately can’t control this). As for reading the LSM files, look at my pipeline attached. Note:
(1) Images - simply drag the LSM files in
(2) Metadata - You MUST click at BOTH “Update metadata” and “Update” buttons
(3) NamesAndTypes uses the “C” channel from the metadata extracted to separate the channels. I knew this by looking at the Metadata module output.
(4) GrayToColor is just for display. Disable or delete it if you like.
(5) I wasn’t sure what channel was which, so the IdentifyPrimary Objects may have incorrect inputs.

Hope that helps!
David
DLpipeline.cppipe (9.66 KB)

Dear David,
Many thanks for the pipeline for reading LSM images.
But I am encountering “error while processing” when I am clicking Update metadata.
PFA the screenshot of the error.

Ashima

Which Update button do you mean? Try this:
(1) File -> Clear the pipeline
(2) Remove all images from the Images list (i.e. clean slate!)
(3) Drag in your LSM file into Images
(4) Load your pipeline
(5) In Metadata, click the “Update metadata” button show here: cl.ly/image/2K0Z0I2a1A3B
(6) After it extracts the metadata (it took quite a few seconds for me), then click the “Update” button at the bottom of Metadata
You should get 3 lines of output, like this: cl.ly/image/313h3N262d2o

Does that work?
David

Dear David,
I did what you suggested and am still getting the same error. Then I tried one more thing. I downloaded the Developer Version (22nd September 2014). In that when I pressed the Update metadata under Metadata, it worked but I am not getting the complete metadata as you are getting. PFA the screenshot of the same. Further down the pipeline, NamesandTypes module doesnot produce any valid Image set in Developer version.

Also I did one more thing, carried out all of what you suggested on my Mac(since you had done the same on a Mac, I thought its may be windows thats faulty). But on Mac as well I am getting similar error as the one I posted earlier.
Super confused as to whats happening.

Ashima


Dear David
I am attaching another screenshot here which I thought will be useful for troubleshooting. Please note that this has all been done in Developer Version.
In the module settings of Metadata, I am getting all the Metadata types that you got in your run. But when I press the Update button(lower one) all the Metadata types are not shown.

Thanks
Ashima


Thanks – I see the issue now too and filed a bug: github.com/CellProfiler/CellPro … ssues/1207
I was using the 2.1.1 release, which does not show the issue. Do you need the Developer’s version?

Thanks,
David

2.1.1 release is not working for me :frowning:
Regarding the Developer’s version, you mean the one in which bug is fixed?
I would certainly need that. Please let me know which date version will that be.

Thank you so much

Ashima

Hey David,
I tried another thing today.
I downloaded CP 2.1.0 version for windows. It worked :smile: :smile:
Just wanted to let you know. May be this helps you guys in some way.
And thank you so much for your help.

Regards
Ashima

Thanks - I added your 2.1.0 experience to our issue which may help.
Cheers,
David