Problem with SLIC tile object classification

Dear all,

I am trying to make an object classifier using SLIC tiles from the readthedocs manual. using version 0.2.0
I first made an annotation of the whole tissue segment. Then I used Analyze > Superpixels > SLIC superpixel segmentation to create the slics. After I added features using analyze > intensity features.
I can find the SLICs in the hierarchy and see that the features are added. I just don’t see the SLICs in the annotations menu.

Then I classified some of these slics (the image shows some SLICs that have been classified, but I had classified many more and got the same error) into classes

However when I am trying to create the object classifier it seems that it doesn’t acknowledge that the SLICs are there: it gives the error that you see below in the screen: you need to annotate objects of at least two classes to train a classifier.

I’ve tried several times but I get the same result every time. Can you see what I am doing wrong?


As far as I can tell you don’t have any training objects. Note that training is defined by “Unlocked annotations.” As far as I can tell from your annotations tab (perfect choice for the image, by the way!), you have no training data.

I would recommend going through this section if you still have questions.

I am guessing you manually assigned classes to some of your SLICs using the Set class button or something similar? You can probably see how that would be problematic for training data, as the class would be immediately overwritten the first time you ran it.

In case it helps, I also have a slightly older guide here.

Thanks so much! This is exactly what I did (selecting the SLICs manually…)
I see what you mean about overwriting when you run the object classification overwriting the manually assigned classes.

I’ve tried again with manually drawing some training annotations and running it from there. Now it works. Thanks again!

1 Like