Problem with processing chains in TANGO

Dear @ThomasBoudier

I am very new at image processing and just started using TANGO. After editting the processing chains as shown in the first two images, I check the required boxes as described in the tutorial and Run it.


A “processing field” message is shown as in image 3.


But after the processing is done (which I am not sure it is), I do not see any lists containing nuclei and structures (image 4) as described in the tutorial.

Also, I see the following error:

segment field:0006.nd2
process field error: 0006.nd2 java.lang.ArrayIndexOutOfBoundsException: 0
tango.plugin.filter.EraseSpots.eraseObjectsSNR(EraseSpots.java:208)
tango.plugin.filter.EraseSpots.runPostFilter(EraseSpots.java:127)
tango.plugin.filter.PostFilterSequence.run(PostFilterSequence.java:71)
tango.dataStructure.Field.postFilterStructure(Field.java:342)
tango.dataStructure.Field.processNucleus(Field.java:280)
tango.gui.FieldManager.processAndCropFields(FieldManager.java:126)
tango.gui.FieldManager.processAndCropFields(FieldManager.java:636)
tango.gui.FieldManager$2.run(FieldManager.java:601)

Kindly tell me what I am doing wrong and how to fix it.

Regards,
Shruti

Hi @Shruti_Patrick,

Thanks for using TANGO, this plugin is not actively developed, but we try to maintain it and answer questions.

It seems that no nuclei are detected, this is why you have an error. To set up a processing pipeline, that is not so straightforward the first time, I would suggest you to use the sample data provided, and also use a step-by-step approach using the test button in the processing field tab, so you can adjust your pipeline.

If you send me the data I can try to help you set up a pipeline.

Best

Thomas

1 Like

Thank you so much for your quick response, Dr. Boudier. The step-by-step approach that you suggested is working for me. There haven’t been any more errors so far. Thanks a lot for your help.

Regards,
Shruti