Problem with loading images - NamesandTypes: matching by order error



Hello everybody,
I am trying to create a pipeline to measure some characteristics in .tiff stack files, containing several timelapse frames. Here is the pipeline: 20180605_fucci_pre-meas.cppipe (9.6 KB)
When I load the images and I extract info from Metadata, everything seems fine. Then, when I update the info provided in the NamesandTypes module, this is what I get:

And if I continue and enter test mode, at the first step I get this Error message:

It seems that a problem occurs in one of the image channel (I split the channels to make it easy to process them with CellProfiler, instead of uploading the multichannel original .tiff file), loosing some positions that cannot be coupled to the same positions in the other channels, or at least this is what I understood. I might be wrong.
Any help to overcome this issue would be highly appreciated!



hy Lucrezia,

I had the same problem a few weeks ago. I can’t excactly describe how i fixed it.

I think, I changed the rules from “file containes” to “dictonary ends with” because my files were saved in folders like …\Green etc. so I could use the End of the folder to sort them.



Hi Markus!
I tried to separate my files into different folders according to the channel but it didn´t help, unfortunately… instead, it gave an error message saying that now 41 images were missing (a whole set). I really don´t know how to fix it, but thank you anyway!!


Hi Lurezia,
Could you please check if you are properly extracting information from folder names?