Problem with installation on 10.8.5

Hi,

I’m trying to install cellprofiler-dev on Mac OS 10.8.5 from mountain-lion branch but I’m getting following error:

libtool: link: cc -dynamiclib -o .libs/libtiff.5.dylib .libs/tif_aux.o .libs/tif_close.o .libs/tif_codec.o .libs/tif_color.o .libs/tif_compress.o .libs/tif_dir.o .libs/tif_dirinfo.o .libs/tif_dirread.o .libs/tif_dirwrite.o .libs/tif_dumpmode.o .libs/tif_error.o .libs/tif_extension.o .libs/tif_fax3.o .libs/tif_fax3sm.o .libs/tif_flush.o .libs/tif_getimage.o .libs/tif_jbig.o .libs/tif_jpeg.o .libs/tif_jpeg_12.o .libs/tif_luv.o .libs/tif_lzma.o .libs/tif_lzw.o .libs/tif_next.o .libs/tif_ojpeg.o .libs/tif_open.o .libs/tif_packbits.o .libs/tif_pixarlog.o .libs/tif_predict.o .libs/tif_print.o .libs/tif_read.o .libs/tif_strip.o .libs/tif_swab.o .libs/tif_thunder.o .libs/tif_tile.o .libs/tif_version.o .libs/tif_warning.o .libs/tif_write.o .libs/tif_zip.o .libs/tif_unix.o -Wl,-force_load,…/port/.libs/libport.a -llzma -ljpeg -lz -lc -O2 -install_name /Users/emilrozbicki/git/CellProfiler/homebrew/Cellar/libtiff-universal/7/lib/libtiff.5.dylib -compatibility_version 6 -current_version 6.4 -Wl,-single_module
brew: superenv removed: -O2
Undefined symbols for architecture i386:
"_lzma_code", referenced from:
_LZMADecode in tif_lzma.o
_LZMAPostEncode in tif_lzma.o
_LZMAEncode in tif_lzma.o
"_lzma_end", referenced from:
_LZMASetupDecode in tif_lzma.o
_LZMASetupEncode in tif_lzma.o
_LZMACleanup in tif_lzma.o
"_lzma_lzma_preset", referenced from:
_TIFFInitLZMA in tif_lzma.o
_LZMAVSetField in tif_lzma.o
"_lzma_memusage", referenced from:
_LZMADecode in tif_lzma.o
"_lzma_stream_decoder", referenced from:
_LZMAPreDecode in tif_lzma.o
_LZMADecode in tif_lzma.o
"_lzma_stream_encoder", referenced from:
_LZMAVSetField in tif_lzma.o
_LZMAPreEncode in tif_lzma.o
ld: symbol(s) not found for architecture i386
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[1]: *** [libtiff.la] Error 1
make: *** [install-recursive] Error 1

Any idea what the problem could be.

Regards,
Emil

Hi Emil,

Not sure exactly. But two questions come to mind:

Thanks,
David

Hi David,

sorry for late reply, I’ve ran it with XCode 5.0.2 and just now repeated with XCode 4.6.3 the same issue.
My pip list gives:
wxPython (2.8.12.1)
wxPython-common (2.8.12.1)

Cheers,
Emil

I have been using the master branch of CellProfiler/homebrew, not the mountain-lion branch. Did you try that?

Hi David,

thanks for help, I installed all dependencies by hand and it seems to work now.

Cheers,
Emil

Ah, ok good. Thanks for reporting back Emil.
-David