Problem with importing CZI files

Hi all,

I’m new to QuPath. I’ve been trying to import .czi files of multiple IF created on Zeiss Axioscan (compressed JPEG XR), however I keep having the same problem: I can open the files and see all the channels, but the signal intensity in every channel is much higher than what it should be. It doesn’t seem to be only a visualization problem because most of the positive signal is saturated and the pixel values are much higher than those observed on Zen at the actual scanner.

Has anyone ever experienced this problem before with czi or other file formats? Is there a way to fix this?

Thanks!!

Worked with a bunch of CZI files before and never seen something like that, but I don’t do as much with the slidescanner, if that is what you are using.

What was the bit depth of the original image in Zen (or pixel ranges), and what is the listed bit depth in the Image Tab in QuPath? It might help to take a Snip of the Image tab and post that, though you could exclude the file name if you needed to.

Hi, thanks for your reply. Yes I’m using the slide scanner.
The original bit depth on Zen is 16-bit and on QuPath the same from what I gather. I’ve attached a few pics of what I see when I open the same czi file on Fiji or QuPath and of the image tab and saturated pixels.

Thanks for any advice!

image
Setting the min and max to the same value will definitely make the images appear saturated. Have you double clicked on the Max Display “Number” to adjust the channel max to something more relevant to a 16bit image?

You can also script these min and max values, but otherwise, I think QuPath takes it’s best guess for min/max (as does most other software).

I get it now! I didn’t know it was possible to change the max display value, and I thought it would adjust automatically to the bit depth or something.

Thanks!

1 Like

It generally does, but for a 16-bit image setting the max to 65535 would often be far too much. So instead (as far as I recall) it uses the max in the image… however, for a whole slide image this involves downsampling to do the calculation quickly, and so might not be the max in the full-resolution image.

1 Like

And I suppose there is the added issue of whether “Keep settings” is checked in the Brightness&Contrast, resulting in values from a previous, dimmer image, being used.
*Which is not the case this time since I can see that it is not checked.

I understand, everything makes sense now! Thanks for your help!

1 Like