Problem with Fiji 3D Viewer (apparently Win10), horizontal black and green lines

Dear all,
I checked the forum for a solution, but couldn’t find any.
I use fiji (ImageJ 1.53f; Java 1.8.0_172 (64-bit) on a Windows10 machine.)

Recently when I started 3D viewer again, I get some horizontal black and green lines (see attached). The log page is empty.
Updating my graphic’s drivers, ImageJ, or reinstallation did not solve the issue.
Interestingly, I found the same on a win10 machine at work.

However, on a win7 computer 3Dviewer worked. So I think it has something to do with an update of Win10.

Maybe it is a known problem and one could provide easy help which I would appreciate a lot.

Thank you very much,
Thomas

P.S.: Maybe this Java3D info log helps, as I think this could be also the problem:
Java 3D properties

j3d.pipeline JOGL
j3d.specification.vendor
j3d.specification.version 1.6
j3d.version 1.6.0-scijava-2-pre11-daily-experimental daily
j3d.vendor
j3d.renderer OpenGL

Rendering properties

textureEnvCombineAvailable true
textureImageUnitsCombinedMax 192
textureAnisotropicFilterDegreeMax 16.0
texture3DHeightMax 2048
textureLodOffsetAvailable false
texture3DDepthMax 2048
textureLodRangeAvailable true
textureHeightMax 16384
textureFilter4Available false
doubleBufferAvailable true
compressedGeometry.majorVersionNumber 1
stereoAvailable false
textureAutoMipMapGenerationAvailable true
sceneAntialiasingAvailable false
compressedGeometry.minorVersionNumber 0
texture3DWidthMax 2048
compressedGeometry.minorMinorVersionNumber 2
vertexAttrsMax 10
shadingLanguageGLSL true
sceneAntialiasingNumPasses 0
native.vendor Intel
textureUnitStateMax 8
native.version 4.5.0 - Build 27.20.100.8337
textureImageUnitsMax 32
textureNonPowerOfTwoAvailable true
textureBoundaryWidthMax 1
native.renderer Intel® UHD Graphics 620
textureCoordSetsMax 8
texture3DAvailable true
textureImageUnitsVertexMax 32
textureWidthMax 16384
stencilSize 0
textureCombineDot3Available true
textureDetailAvailable false
textureCubeMapAvailable true
textureSharpenAvailable false
textureCombineSubtractAvailable true
textureColorTableSize 0

UPDATE: I found a Win10 computer on which 3D viewer works. It uses Intel® HD Graphics 4400 as native renderer and j3d.version “1.6.0-scijava-2-pre11-daily-experiment daily”.
So I have no clue for what reason it doesn’t work on my system.
Cheers,
Thomas

Hi,

The issue is with the GPU/CPU usage. See here: Messed up 3D viewer

Basically, you need to whitelist Fiji on your GPU

Hope this helps.

Matthieu

Hi Matthieu,

Thank you very much! You comment was extremely helpful!

My solution involved:

  1. Change graphics used from Intel to Nvidia
  2. follow this guide in that forum: https://www.pcspecialist.co.uk/forums/threads/nvidia-how-to-white-list-games-and-how-to-enable-nvidia-gpu-monitor.18426/

(It involves adding Fiji to the list of software which is supported by the nvidia on my computer).

Thank you very much for the kind help!
Cheers,
Thomas

1 Like