Problem using the pipeline 3 provided by Beth

S16-chol_FirstFrame.tiff (8.0 MB) S16-chol_FirstFrame_Objects.tiff (8.0 MB) Cells.csv (69.8 KB)
cannot get pipeline 3 to work.

Beth provided a model set of 3 pipelines for me for analyzing a time-lapse movie of cultured cells in which bright cytosolic fluorescence flashes on and then off in about 10% of the cells during the 30 min movie (121 frames). Pipeline 1 generated a single tiff image from the 1st frame of the movie. Pipeline 2 generated an object mask and pipeline 3 uses the first two .tiff files and the delta vision movie (.dv) and supposed to calculate the intensities, etc. from each cell (object) in each frame (121). Unfortunately, the final output shows only data from one frame (image number 1), whereas it should show data from all 121 frames. Help?
Experiment.csv (13.0 KB) Image.csv (4.0 KB) Cells.csv (51.4 KB) ActivatedCells.csv (290 Bytes) [3_Analyze 3.10.21 3rd try.cpproj|attachment]

S16-chol_FirstFrame_Objects.tiff (8.0 MB) 3_Analyze 3.10.21 3rd try.cpproj (1.5 MB)

Hi @Monty,

The Metadata module sometimes struggles to keep track of whether metadata was extracted from images in a loaded project from another machine. After you’ve loaded your images into the pipeline, did/could you head into the metadata module and specifically click the “Extract Metadata” button in the module settings? This should trigger a popup which will pull the relevant information. Please note that the preview table at the bottom of the Metadata module may not properly display the image list until you view another module and return back again.

Hope that helps

Unfortunately, it did not work - still only analyzed one frame

. I attach screen shots of the Metadata module and the Images module. HELP!!!

do you need me to post anything else? This is so frustrating.

Okay, could you try adding another “extract from file headers” method in the Metadata module, remove the original (just change it to something else) and see if that fixes it.

I don’t understand exactly what you want me to do. Could you be more specific? exact steps?

I don’t understand exactly what you want me to do. Could you be more specific?

Go to the metadata module.

Change the first extraction method to something else, just as a placeholder. “Extract from file names” would do.

Scroll to the bottom of the module, hit “add another extraction method” and select the “Extract from image file headers” option. Click the “extract metadata” button.

Click the “update table” button, then maybe view another module and then return to Metadata (to refresh the table display).

If that doesn’t work please upload the proper image file.

Dear David,
1st: I really appreciate your taking the time to help me.
2nd: I am brand new to using Cell Profiler and I don’t fully understand most of the fundamental steps yet.
3rd: when you say “Change the first extraction method to something else, just as a placeholder.” I am really not sure just what to do or where to do it. I am sorry to be so dense.
4th: To help, I have labeled each line of the Metadata with a number (see attached) and perhaps you could tell me on which line I should make a change and then explicitly what I should change it to? I am sorry for being so dense and slow and taking so much of your time - but I do appreciate it. Monty

No problem. Using your diagram:

Change dropdown 1 to anything else. It doesn’t matter which option you pick, we just need to make sure that this file header extraction is removed in case it was somehow corrupted.

Now we want to add another extraction method. If you scroll down in the module (below where button 10 is) there should be an “Add another extraction method” button. Click that, then you’ll get another chunk of options. We’ll need to set the Extraction Method (equivalent to boxes 1 or 4) in that to “Extract from image file headers”. Then press the “Extract Metadata” button that would appear below this.

Hope that’s clear

I did what you said, but now I have mover of the sections and don’t know what to do next. I suspect I need to get rid of some of them and reset some of them, but that is not clear. I attach a screen shot with numbered lines
I need more explicit instructions

Press #23, then “Update table” (11 from the first diagram).

wow - that certainly changed a lot in the table at the bottom!!
Looks like I now have in the table my 121 frames of the movie, but twice! I presume I have to get rid of one set of them. There are 243 entries in the table. 242 of them are the 121 x 2 frames from the movie. the last one, #243 is the Objects (the mask?).
so how do I get rid of the extras?

Glad to hear it. Just to check - before all this had you tried clicking the “Extract metadata” button between 3 and 4 in your first diagram?

Unfortunately I can’t tell you what the extra frames are from this description, is it possible that the movie captured multiple channels?

Is there any way we could do a zoom meeting to do this real time and get it done? I did a little waiting for your reply and I think I screwed stuff up and now have a problem with the Names!

I just cannot seem to get this right. I need help. Is there any way someone could zoom live with me to walk through what is needed. It seems like we were close but I keep getting errors in the Names and duplications or triplication of the frames in the movie.

You can always revert back to the pipeline you originally loaded. Right now it’s late at night on a Friday, you might be able to get more help next week. Until then you may want to check out some tutorials.

I look forward to being in touch with someone so that I can get the Names and Metadata right and thus be able to use CP - MK