Problem to measure a area

fiji
imagej

#1

Hello,
I made images with the videomicroscope and ZEN images.
I would like to measure a bone volume (area), but I have a problem, the value is not good.
I have area differences between the images before and after threshold (not on the top of the picture) but but when I measure by drawing a square. I don’t think the threshold is supposed to change the area of the image.
I specify that I tried by putting the real dimensions (set scale: 1pxl = 0.1615µm) or by putting in pixel. I still have problems with measured areas that are wrong. I tried directly with the original image (.czi) or in tiff/jpeg without results.
I also have another problem. When I measure areas using the wand tracing tool or polygon selections. I get very different things.


For example on this image, I drew the shapes 1 (left) and 3 (right) with the wand tracing tool and the shapes 2 (left) and 4 (right) with polygon selections.
The values of 1 and 2 or 3 and 4 are not at all comparable. Moreover, the area of the right shape is more important than the left one, but with the wand tool, I get the opposite.
Can you help me ?


#2

@Melanie_Dhayer

Can you attach here the original image or at least the binary image you are using? So we can get our hands on it to test things? If you look at the top of your image - you can see the size, as well as the scale that is applied to the image (whether in pixels or um).

If you provide the raw, original image - we can better help you develop a full workflow… just let us know exactly what you wish to measure. We’ll get you some help.

eta


#3

the image is too big to be put on the site, here is the link to access it: https://drive.google.com/open?id=18ndv4C_SXFViMhX5Q23towT-CHYP7cRd
In order to do the analysis, I do:
Analyze>Set scale>
Distance in pixels: 1
Known distance: 0.1615
Unit of lenght: µm
Global
When I check the area of the image, in order to make a modification it is correct.


then I make a treshold to get the bone and the area of my image is totally modified.

it’s just an example, but my objective is to measure the bone (in black)
Thank you !


#4

@Melanie_Dhayer

I don’t think there is anything ‘wrong’… just a misunderstanding somewhere in your pipeline. I did the following steps - and all the measurements were the same:

  1. Import the image via Bio-Formats - this is recommended for opening all images in Fiji
  2. I set the scale according to your specifications… though if you import via Bio-Formats, the scaling should be read in correctly from the metadata… and you might be able to remove this step
  3. Use the command “Select All” and then “Measure” … I got the same values you did in the top image (no need to save a ROI to outline the image).
  4. I then set a “Threshold…” - I just used ‘Otsu’ and then “Create Mask” to get the binary image (no size-change should occur when creating the binary mask from your image - they are the same size still)
  5. If again you use the command “Select All” and then “Measure” on your mask image … you will get the same values you did in the top image. Ie - Select All selects the entire image outline and then the measurement is the same.

If you want to measure the area of your ‘black’ pixels… then you need to use the “Create Selection” command and then “Measure…”. That command is what “Creates a selection from a thresholded image or a binary mask.”

You can read/practice more on Segmentation in Fiji/ImageJ with these helpful links:

Hope this helps! If you have more questions… just ask.

eta