Problem in Tile module CP2.1

Hi,

I have problems when I use the Tile module (I used CP2.1 rc11 - 2010115).
When I use this module it runs well in Test mode. When I have several image to be analysed it runs well (tiles are created and I am able to save them) but it seems to prevent to close the pipeline. If the pipeline contains the ExportToSpreadsheet module at the end, no data is saved.

If I try to stop the pipeline, CP crashes.

I have an example pipeline (I occurs also in others), iamges and log files as attachment.

After the last image has been analysed, the logging is like this:

[quote]> c:\program files\peter\cellprofiler 2.1 - r2014-01-15 rc11\cellprofiler\modules\tile.pyc(271)post_
group()
get_completer
set_completer
parse_and_bind(“tab: complete”)

(False, False, False, ‘tab’) -> complete<<<
(Pdb) Worker 0: Connecting at address tcp://127.0.0.1:55679
Worker 1: Connecting at address tcp://127.0.0.1:55679
Worker 2: Connecting at address tcp://127.0.0.1:55679
Worker 0: Connecting at address tcp://127.0.0.1:55679
Worker 1: Connecting at address tcp://127.0.0.1:55679
Worker 2: Connecting at address tcp://127.0.0.1:55679
Worker 0: Connecting at address tcp://127.0.0.1:55679
Worker 1: Connecting at address tcp://127.0.0.1:55679
Worker 2: Connecting at address tcp://127.0.0.1:55679
Worker 0: Connecting at address tcp://127.0.0.1:55679
Worker 1: Connecting at address tcp://127.0.0.1:55679
Worker 2: Connecting at address tcp://127.0.0.1:55679[/quote]

keeps continuing…

After stopping I get this logging and I can’t use CP anymore:

[quote]Stopping workers
Worker 2: HDF5Dict.del(): c:\users\pvl\appdata\local\temp\Cpmeasurements9nuwzd.hdf5, temporary=T
rue
Worker 0: HDF5Dict.del(): c:\users\pvl\appdata\local\temp\Cpmeasurements51jjlx.hdf5, temporary=T
rue
Worker 1: HDF5Dict.del(): c:\users\pvl\appdata\local\temp\Cpmeasurementsesvrie.hdf5, temporary=T
rue
Worker 2: Exiting the JVM monitor thread
Worker 0: Exiting the JVM monitor thread
Worker 1: Exiting the JVM monitor thread
Worker 2: Entering run loop
Worker 2: Running module Images 1
Worker 2: Running module Metadata 2
Worker 2: Running module NamesAndTypes 3
Worker 2: Running module Groups 4
Worker 2: Running module ColorToGray 5
Worker 2: Running module Tile 6
Worker 2: Running module SaveImages 7
Worker 2: Cancelling worker
Worker 2: Exiting run loop
Worker 2: stopping worker thread 0
Worker 2: stopping worker thread 1
Worker 2: stopping worker thread 2
Worker 2: stopping worker thread 3
Worker 2: stopping worker thread 4
Worker 2: stopping worker thread 5
Worker 2: stopping worker thread 6
Worker 2: stopping worker thread 7
Worker 2: stopping worker thread 8
Worker 0: Entering run loop
Worker 0: Running module Images 1
Worker 0: Running module Metadata 2
Worker 0: Running module NamesAndTypes 3
Worker 0: Running module Groups 4
Worker 0: Running module ColorToGray 5
Worker 0: Running module Tile 6
Worker 0: Running module SaveImages 7
Worker 0: Cancelling worker
Worker 0: Exiting run loop
Worker 0: stopping worker thread 0
Worker 0: stopping worker thread 1
Worker 0: stopping worker thread 2
Worker 0: stopping worker thread 3
Worker 0: stopping worker thread 4
Worker 0: stopping worker thread 5
Worker 0: stopping worker thread 6
Worker 0: stopping worker thread 7
Worker 0: stopping worker thread 8
Worker 1: Entering run loop
Worker 1: Running module Images 1
Worker 1: Running module Metadata 2
Worker 1: Running module NamesAndTypes 3
Worker 1: Running module Groups 4
Worker 1: Running module ColorToGray 5
Worker 1: Running module Tile 6
Worker 1: Running module SaveImages 7
Worker 1: Cancelling worker
Worker 1: Exiting run loop
Worker 1: stopping worker thread 0
Worker 1: stopping worker thread 1
Worker 1: stopping worker thread 2
Worker 1: stopping worker thread 3
Worker 1: stopping worker thread 4
Worker 1: stopping worker thread 5
Worker 1: stopping worker thread 6
Worker 1: stopping worker thread 7
Worker 1: stopping worker thread 8
Canceling run
Waiting on interface thread[/quote]

Regards,
PeterTest Tile 1d.cpproj (291 KB)
Test Tile 1d.cpproj (291 KB)


Hi Peter,

Thanks for notifying us of this problem. I’ve been able to reproduce the bug, and have filed a bug report on it: github.com/CellProfiler/CellPro … ssues/1027. We don’t have a workaround, but I will repost here when a fix is implemented.

Regards,
-Mark

Hi Mark,

It seems to be fixed already in the official CP2.1 release of 24 january 2014.
Thanks a lot!

Regards,
Peter

Yes, this Github issue has been closed. Glad it works for you!
David

This issue has been resolved with the 2.1.1 release.
-Mark