Problem (Error) in conversion from Pixel Classification to Auto-context

Hello!
I am trying to move from pixel classification project to auto context project, as described in this thread:
Changing project type in ilastik?

It seems the project is loading fine, but then, after choosing features and pressing “training”,
I get the following error:
image

After pressing “OK”, the program seems to be stuck.

I am using ilastik 1.4.b5, and currently downloading the stable 1.3.3 to see if it solves the problem.

I would appreciate thoughts of this problem and ways to solve it,
Thanks!

Update:
I have tried to import with ilastik 1.3.3, and received the following (maybe more informative) error:
image

Hi @Tomer_Basan,

I’m afraid we’ll need some more detail on that. I tried to reproduce this in 1.4.0b5 with some 2D, 2 classes data and import worked. Could you maybe tell us a little more on what you had there in your project? Did you have multiple input files, how many classes, which features selected?

Cheers, hope we can resolve this swiftly.
Dominik

Feel free to ask for more details if needed, And ill try to answer as fast as I can!
In my source project which is pixel classification (and I wish to make It auto-context) there are:

20 input images (2d images, all of them 500x500 pixels)
31 features selected (everything in sigma_1 to sigma_5 and one feature for sigma_0)
3 classes, each image has at least one mark of each class.

I have already exported from this project results, so I’m guessing it is not path-related issue

Thanks.

Hi @Tomer_Basan,

thank you very much for providing the details. I have tried it with your settings, and some 20 500x500 random images and the import worked for me. Could you maybe delete your log file (it’s in C:\Users\<YOURUSERNAME>\ilastik_log.txt, then try the import again, and then maybe post the contents of the log file after it failed?

Best,
Dominik

Sure, I did as requested:
and here is the log file:
ilastik_log.txt (53.8 KB)

while this is the last error:

File “C:\Program Files\ilastik-1.4.0b5\ilastik-meta\ilastik\lazyflow\operators\ioOperators\opFormattedDataExport.py”, line 194, in setupOutputs
assert type(output_drange[0]) == export_dtype
TypeError: ‘NoneType’ object is not subscriptable

Thanks again, Tomer.

Hi @Tomer_Basan,

thanks so much for supplying the log file! Unfortunately, it was not very revealing :confused: Would it be possible for you to share one of your data files with us? You could do so via this file drop (valid only for 24 hours).