Problem accessing the object count data in CalculateMath

I cannot get access to the red or green segmented object count to calculate the ratio of red objects to green stained objects. I posted a frozen section image used for the attached pipe. I know both filtered object counts are measured because I have found the data in the image output xls file,but can I calculate the ratio with CP and output the pre-calculated values instead? Also, can anyone suggest a better nuclei segmentation method for the attached image? I find that the calculated integrated intensity to cytoplasm area ratio measurement is skewed when the nuclei segmentation merges two neighboring cell nuclei.
1-26-10 40x HER2-Cytokeratin jpg PIPE.mat (2.25 KB)


Hi Derek,

Re: segmentation - Based on your pipeline, and some tweaking of my own, I would say that you are doing as well as you can be, at least on the basis of this one image. Your nuclei are very heterogenous in intensity, shape and size, and so you would be hard pressed to segment them perfectly. It looks like you’ve done quite a bit of tweaking of the settings on your own already, so I don’t have any suggestions myself (although hopefully another user might).

Re: CalculateMath - Assuming that the red objects are FCyto in the pipeline, it turns out that ExpandOrShrink doesn’t output an object count for them. A workaround to get the count would be the following modules after ExpandOrShrink :

  • ConvertToImage with the binary setting to change the objects to a binary image.

  • IdentifyPrimAutomatic to re-identify the objects and produce a count. Set all the “Discard…” options to No, the thresholding method to Other with a value of 0.5, and “Do not use” for “Method to distinguish clumped objects…” Call these objects FCyto, and give the objects in ExpandOrShrink a different name so as not to confuse them.

Then add a CalcMath module with the operation as “Divide”, the 1st operand as “Image”, category “Count” and feature as “Other > FCyto” and the 2nd operand as “Image”, category “Count” and feature as “FilteredCytoplasm.”

Hope this helps!
-Mark