Prevent Fiji updating when running in headless mode

Hello,

is there a way to prevent Fiji from searching for updates when running headless mode from command line? I want to submit it as a cluster job and but it creates some errors mentioning http and timeout so I assume that it is trying to update.

My command looks something like this:
/fijifolder/Fiji.app/ImageJ-linux-64 --headless --console --mem 16G -macro /path/to/macro.ijm

I was searching for another flag around something like no-update but couldn’t find anything.

Thanks already!

1 Like

This was fixed by @frauzufall in a recent pull request:

The fixed version (0.10.4) is not yet available via automatic updates, but you might want to test it by placing imagej-updater-0.10.4.jar into your Fiji.app/jars/ directory, and removing any older versions.

3 Likes

Thank you for this link, will give it a try!!

1 Like