Possible bug using Threshold tool ImageJ 1.53c

Hello,

Yesterday, I updated my ImageJ version from 1.52p to 1.53c. I’m trying to use the Threshold tool to segment an image. When I open the threshold tool, I’m able to move the sliding bars and adjust the lower and upper limits of the threshold. However, when I try to input the number using my keyboard and after I finish typing the number, the number is reset to whatever number was set using the sliding bars. Is this potentially a bug?

Thanks,

JR

1 Like

Hm… it seems that it is a bug at least from 1.52v (worked as expected in 1.51w, but I cannot see the Set button in 1.51w). @Wayne might be able clarify.
You can get round that by using the Set button instead of typing the value in the threshold display boxes.

1 Like

Hi @gabriel,

The Set button solved my issue. However, it would be nice if this could be addressed so that we are able to directly type it without having to use the Set button.

Thanks!

This regression is fixed in the ImageJ 1.53d37 daily build.

1 Like