Plugin scripts no longer appear in plugin menu on mac osx



This is an odd issue that I cant figure out:
I wrote a few simple jython scripts added them to a folder, and dragged that folder to my directory. I could then see and run the scripts from my Plugins menu. I made an update site and added these scripts to it for easy distribution to my lab (called Lab-utility-plugins , source: – you can see the names are formatted properly with _ and .py). This was all fine, but I recently updated Fiji, and the scripts all disappeared from my machine. I removed and added the update site, uninstalled and re-installed Fiji, still no luck.
I tried adding other dummy files to my plugins folder, things like test_.clj test_macro.ijm test_ja.jar` and still nothing shows up.
Oddly, everyone in my lab and friends are able to install and use the plugins from the update site still. I tried a fresh install on a Windows machine I have access to and again it worked without a problem. I am stuck-- it seems like my plugins folder is no longer checking for updates.
any help would be appreciated.

java info:

Nicholass-MacBook-Air:~ Nick$ java -version
java version "1.8.0_144"
Java(TM) SE Runtime Environment (build 1.8.0_144-b01)
Java HotSpot(TM) 64-Bit Server VM (build 25.144-b01, mixed mode)

Updator crashes Fiji

This issue was discussed here as well:

The issue seems to appear on Mac OSX only. The workaround I mentioned there is to put the scripts into ./ instead of ./

In your case, this would mean to move your scripts from:

  • ./


  • ./

I didn’t have time to investigate further what’s causing the issue, though.


Thanks for pointing me at that post, I didn’t see it before. The workaround does indeed add the scripts to the main menu at the top of the screen. I’ll keep an eye out for updates and in the meantime I’ll change the update site to install to scripts/Plugins/ if that is possible. Thanks.


I have committed a fix for this issue, as described here:

I will cut a new release and upload to the core update site before the end of the week.


Thanks for your help and the prompt fix @ctrueden and @imagejan!