Pb runnning Fiji in headless mode

Hi all, maybe particularly @ctrueden

I am trying run jobs on a server that will use Fiji in headless mode. I noticed that when Fiji wants to update it may break the jobs. Is there an option to turn the update to never ?

I do not know if it is related but after launching 3-5 jobs launching Fiji, it may also crash, is there a limitation in the number of instances ?

Thanks

Best

Thomas

To complete the topic, it appears that in batch mode, the running macro may stop because Fiji is trying to update. Is there a way to set the update option to never ? Thanks.

Here are discussions about that with potential solutions:
http://imagej.1557.x6.nabble.com/Blocking-Fiji-s-Updater-td5005907.html

Cheers,
Christopher

1 Like

@ThomasBoudier Please let us know if deleting jars/imagej-updater.jar works for you. If not, we can discuss ways to improve ImageJ2 to do what you need. (My vote would be a system property imagej.update.policy or some such that would be respected by the UpdateService.)

1 Like

Hi @ctrueden and @schmiedc,

Thanks for pointing me to this thread, I just tried to delete the imagej-updater.jar and it seems to work nicely. I guess an option somewhere to change the settings for the updater would be nice, it is a bit frustrating that you can only specify the updater behaviour only the first time.

Thanks again

Best,

Thomas

1 Like

We just started some work to improve Updater behavior for cluster jobs, including:

  • Do not check when running headless.
  • Only auto-check once every 24 hours.
  • Completely disable updater auto-checks by passing -Dimagej.updater.disableAutocheck=true.

Hopefully we’ll finalize this work and merge/release soon.

2 Likes