ParticleSizer: Difficulty configuring R w/Rserve_1.8-0.zip for Fiji/ImageJ 1.52g

@twagner - I apologize for the post but, need input to resolve my inability to have R execute as desired when running your ParticleSizer plugin. I have read your document (http://imagej.net/ParticleSizer#Installation) carefully yet, see no further point in attempting to work with ParticleSizer because, R 3.5.1 does not want to install Rserve_1.8-0.zip. When I attempt to do so, I receive no message in the R console. In contrast, when I proceed to install the second package required, MASS_7.3-45.zip, the following message is displayed in the R console:

“package ‘MASS’ successfully unpacked and MD5 sums checked”

Additionally, note the sub-directory/folder MASS appears in the R-3.5.1/library folder as expected whereas, Rserve does not. This result seems consistent with the lack of a message indicating proper unpacking of the local zipfile. I am assuming Rserve_1.8-0.zip is a binary file. Your instructions would indicate otherwise.

My early attempts to use ParticleSizer demonstrate Fiji 1.52 is fine with regard to the plugin yet, R is the difficulty. For example, R informed me Rserve_1.8-0.zip was built with different internals and must be re-installed. I took two actions to resolve this message:

1 - Update Rserve from a mirror located near me. This gave me Rserve_1.7-3. I tried to use this file and R does like this version. However, using Rserve_1.7-3 with ParticleSizer does not work either and displays a different message in the R Console:

"[ERROR] File has length 0 and may be corrupt Rserve>Starting Rserve… Rserve> “Path on my pc to
Rserve.exe” --no slave --slave

2 - Remove/re-install R 3.5.1 from my laptop (omitting the 32-bit files this time). Repeat R setup with Rserve_1.8-0.zip. Same results as above. Fiji appears happy, no R output or graphs displayed.

I am using an older laptop featuring a Core i5 M-560 @ 2.67 GHz, 8 GB RAM and 64-bit Win7 Pro. I chose the default install location for R (C:/Program Files/R) yet, Fiji resides in a remote sub-directory. Previous discussions on this forum (First release ParticleSizer) suggest this should not be a factor contributing to my experience but, I do not know the reason for these. I am following both the Biomedgroup and ParticleSizer update sites as you indicate and I am setting the R path to the R BIN folder in the plugin setting manager (sometimes I am required to repeat this setting before it becomes persistent).

At the moment, I can only scratch my head in wonder.

Thank you,

Rick

Dear Rick,

I have faced exactly same problem, and I solved it with a very simple method!

After installing MASS_7.3-45.zip, type

install.packages(“Rserve”)

in R console.

This will solve your problem ! I did this and I got a nicely plotted image.

Hope my answer will help you solving the problem.

Nightsky

1 Like

@nightsky

Thank you for your response. I need to know more about your computer; the OS, version of R, did you define a directory/location to store packages in, etc., to know if this will work for me because, this is a standard command for installing packages an also has failed to work for me.

At the moment, I must assume you are working with a computer equipped in a similar manner to my own but, should ask about this to be certain. I recently installed Ubuntu 18.04 LTS in a dual boot OS configuration on this same laptop but, have yet to attempt working with R under this OS.

Rick

Dear Rick,

Please find attached photo files. Hope these will help you finding the solution.

  1. OS of my laptop

  2. version of R
    Rversion