Particle Sizer error message: Unrecognized command: :Is global calibration"

imagej

#1

I intalled NanoDefine Plugin, but when I load an image and click on Particle Sizer I got an error message saying Unrecognized command: “Is global calibration”. Is there a way of fixing this? Does Particle Sizer works with any type of image? Do I need to pre-process the image in a specific way first?


#2

Hi @humbertohall

Welcome to the Forum!

Did you read the ImageJ wiki page on ParticleSizer?

What version of ImageJ are you using? Might be best to install/use it via Fiji. Fiji is Just ImageJ - it is simply a distribution of ImageJ that comes with a bunch of plugins bundled - ready for you to use out-of-the-box. You can download Fiji here.

On that ParticleSizer page - they say how to best install the plugin via update sites… perhaps there was just an installation issue?

Hope this helps a bit! If not - @twagner can better assist you… :slight_smile:

eta


#3

Hi @humbertohall,

I seems that you did not use the installation via update site and some packages are missing. Please try it again via update site.

Best,
Thorsten


#4

Hi @twagner,

I did it again via update site as per the manual

Now it starts to run but I get the new following error messages:

The image I wish I could find the size distribution of the round bubbles is this one. The red contours you see in the image was drawn by Particle Sizer before it stopped running and right before it popped up the window with the errors.

Another problem that I faced was the installation of Reserve and Mass Packages for R. R intalled ok but when trying to install the two packages it gave the same error for each one of the packages

I tried to open the manual for Particle Sizer through the Plugins- NanoDifine - Open Particle Sizer’s Manual, but it gave an error as well.

Do I really need to install R and the two packages to run Particle Sizer?

Should I completely un-install Image J and then start from scratch? I am using Fiji actually, should I work with Image J Instead?

Thanks for your help.


#5

dear @humbertohall
I used a lot particlesizer I think the problem of the image not recognized is the presence of the spaces in your filename (try to rename them without spaces I think it will work since I had the same problem and solved that way)
or maybe @twagner could try to fix that bug in the code.

about the R issue I had similar issues when I tried to install the plugin on a Mac and I solved it unchecking the plot distribution box in the particle sizer settings window.
in windows it works fine with R and it plots very nice graphs😁
but it’s not necessary to have R except for nice graphs.
you will be able to export a results table and do you plot and analysis how you will prefer.

hoping to be helpful,
have a nice day
Emanuele Martini


#6

Hi @humbertohall,

its indeed a naming issue. Please rename your image that it does not contain “-” or “_”. I will fix it as soon as possible.

For the R installation issue: You could try to install the packages on mac by opening the terminal and type:
R
install.packages(“MASS”)
install.packages(“Rserve”)

Don’t forget to set the path to the R binary in the Settings Manager

Best,
Thorsten


#7

@humbertohall
I can add a suggestion that I always give to the researchers in my campus: please try to avoid spaces and strange symbols in the names :wink:
anyway thank you @twagner to try to find time to fix it.

regards,
Emanuele Martini


#8

I’d consider this a flaw in the macro. I proposed a fix here:

https://github.com/thorstenwagner/ij-particlesizer/pull/3


It is a little sad that we still have to recommend this, but it certainly helps.

Nowadays (with all the scripting power available in Fiji) script and plugin programmers should have no problems dealing with strange characters in names, and I’d say they should always test their scripts with a few files covering these cases.


#9

@imagejan
Thanks for your fix! Unfortunetely the particlesizer is still not well covered with unit tests :-/

@humbertohall
Could please replace the version with the following and give feedback if the issue is resolved?


#10

Thorsten,

Particle Sizer is working now. Also I used a file containing “-” in the file name and there were no issues.
Thanks for y’all help. It is an amazing community.


#11

The new version is now available through the update site.


#12

Hi @twagner,

Sorry to say that R is still not working for me. I know I could use other plotting tools but I am just curios about R, so I would like not to give up yet on R. I see you highlighted to “dont forget to set the path to the R binary in the settings manager” and the installation guides for Particle Sizer also mentions the same “Open Fiji, start the ParticleSizer Settings Manager and the R path to the R binary.”

But I got confused here. My Particle Sizer setting manager does not have a “R path” or a “Rbinary” option

So, if you don’t mind, how “to set the path to the R binary in the settings manager”?

Before running the Particle Sizer, are there any actions to take in R? Do I leave them both opened in my lap top simultaneously? ( I just use use a regular Asus laptop with windows 10)

I manage to install the MASS and the Rserve packages successfuly but I had to go get it directly from the web page https://cran.uni-muenster.de/, in the “available packages section”

The error messages pop up when I keep the “Do not plot size distributions” unchecked in the Setting Manager and it says “failed to start Rserve”

I am using R version 3.4.0 (2017-04-21) - “you stupid Darkness”.
I will try “R version 3.4.1 (Single Candle) prerelease versions will appear starting Tuesday 2017-06-20. Final release is scheduled for Friday 2017-06-30.” just to try again.


#13

@humbertohall I updated the ParticleSizer. Please update and check of you can set the path.


#14

@emartini Hi, I can reproduce your problems on the Mac. I will fix it as soon as possible:
https://github.com/thorstenwagner/ij-particlesizer/issues/4


#15

@twagner I still can not set the path. The operating system I am using is 64-bit OS, x64-based processor


#16

Hi @humbertohall, I can’t reproduce your problem. Would you be so kind and try if the problem still exists if you do a fresh installation? So, download latest fiji and install the particlesizer via the update site?


#17

Hi @twagner. Everything is working know - I was able to get an R plot at the end.

When I installed the particle analizer just now, it showed the option to “set R install directory” in the settings manager window. I just would like to highlight that when intalling R, the installation R folder had to be inside the Fiji folder, otherwise it wouldnt work.


#18

Hi @humbertohall ,

I’m happy to hear that everything is working now. However, I’ve installed R on many Windows machines and it was always enough to the set the path to the R installation directory (that directory which contains the folder “bin”).

Best,
Thorsten


#19

You are right. It also worked when setting the path to the R installation director (the one with the “bin”). I did mess up. Thanks!


#20

I went all the way to this step:

“Open Fiji, start the ParticleSizer Settings Manager and the R path to the R binary”

After opening Fiji, I am not sure where to find ParticleSizer settings manager to start? any help will be appreciated.

Kumar