OverlayOutlines in color

Hi,
I have created a pipeline in CP but when I test run the OverlayOutlines module, where I selected output in color, I only get a grayscale image. Is there a bug here or is there something I’m doing wrong?
I attach the pipeline as well as the test set of images.

Thanks in advance!

Elin
E65_processing.cpproj (540 KB)





Hi Elin,

Hmm, the saved image has color outlines when I run it on my Mac. Nothing appears wrong in your pipeline re: the outlines. Indeed, the outlines are fairly dim if I view it in Preview on my Mac, but if you load the output image back into CellProfiler it appears nice and bright, and in color (see attached).

If this is not what you’re seeing, can you let us know what version of CP you are running, as well as what OS (e.g. Windows 7)?

Thanks,
David


Hi David,

Thanks for your reply. The images I use should be exported as original tiff files in grayscale by our microscopy software so it is a little puzzling that they look different on your Mac. I’m running Windows 7 and the latest release of CellProfiler (I downloaded it last week). I have also noticed that the images are quite dim and dark if you only look at the original image files but in CellProfiler they do indeed look bright and nice. I attach the output image I get from from the OverlayOutlines module. It’s all black and white. It is the color image that you attached that I would like to get.

Let me know if there’s anything else you need to know.
Thanks!

Best,
Elin
OverlayOutlines output.pdf (980 KB)

Hi Elin,

In my testing, I see the behavior you reported, and only on Windows. But this is a bug that has been fixed since our last release. Please try our release candidate 2.1.1 with the bugfix here: cellprofiler.org/cgi-bin/trunk_build.cgi

Let us know if that helps.
David

Hi David,

I downloaded the latest release and ran the pipeline again. This time it worked the way it should.
Thanks for all the help!

Best wishes,
Elin

That’s good to hear!
David