Opening RAW Images Without Headers, DICOM error pops up instead of Import->Raw

So when I was using 1.48v I had no problems opening RAW files which have no headers from windows explorer. ImageJ would open and display Import->Raw dialog, and I would input the image dimensions and type.
I just upgraded to 1.51k and instead of the same behaviour, I have inconsistent behaviour where sometimes Import->Raw dialog pops up, other times an error dialog shows up saying DICOM Reader: DICM not found at offset 128.
How do I make imagej open RAW files using import->raw dialog from windows explorer and other navigation applications consistently?

Please provide an example image so we can reproduce the problem.

Tried to reproduce it on some RAW images but couldn’t today.
I did notice a pattern though, when opening an image which that version of ImageJ has not opened before, no matter how many times or ways I tried to open the image, from explorer or drag dropping into imageJ, it’d think it was a DICOM file but if I did import RAW on that filename, it’d open fine, and then open fine after that consistently just by drag dropping or opening from explorer.

The RAW file is easy to generate, it’s just a 12bit data written into a 16bit per pixel sequentially, without headers.

Please provide an example image that we can use to reproduce this problem. There is probably sequence of bytes at or near the beginning of the image that causes ImageJ to assume is is DICOM format.