Opening .lof Leica files

Hello All,

Is the community aware that the new .lof file format from Leica is not able to open in FIJI?

This file type is generated when we autosave on our Leica SP8X, rather than saving the data at the end as a .lif.
Does anyone know when this file type will be supported on FIJI?

Many thanks,

Darren

Hey @Darren_Thomson

Sorry for the late reply… How exactly are you opening the file in Fiji? Are you using Bio-Formats? If not, I’d suggest giving it a try… will be the best option for you at the moment.

There was a recent forum post regarding new release…

If you have further issues - please post a response. Hope this helps a bit!

eta :slight_smile:

Hi @etadobson
I’ve opened in with drag/drop and by importing in BioFormats and still no luck.
It’s a new file format created by Leica for autosaving, I have a pdf of the release notes from Leica and they told me that they sent all the info to Bioformats etc.

“New Extended Leica File:
 Extended Leica File: Leica-specific project data format in which the metadata and image data are stored separately. For each data object, both a binary file and a metadata file are written. The Extended Leica File can be used during image acquisition if the “Auto-Save” function is enabled (see next section). The format is compatible with image data and also other data objects.
Which image data type to choose when working with the new Extended Leica File?
 TIFF: Tagged Image File Format. Saves each individual image in a separate file. Suitable for black-and-white images and recommended for smaller volumes of data. Image data directly accessible by other programs
LOF: Leica Object File. Well suited for large data volumes. Serves also as back-up file format if the data object cannot be stored as TIFF.

The error I get when trying to upload in Bioformats:

loci.formats.FormatException: Invalid Memory Block: found magic bytes 298, expected 112
at loci.formats.in.LIFReader.initFile(LIFReader.java:437)
at loci.formats.FormatReader.setId(FormatReader.java:1399)
at loci.plugins.in.ImportProcess.initializeFile(ImportProcess.java:498)
at loci.plugins.in.ImportProcess.execute(ImportProcess.java:141)
at loci.plugins.in.Importer.showDialogs(Importer.java:140)
at loci.plugins.in.Importer.run(Importer.java:76)
at loci.plugins.LociImporter.run(LociImporter.java:78)
at ij.IJ.runUserPlugIn(IJ.java:217)
at ij.IJ.runPlugIn(IJ.java:181)
at ij.Executer.runCommand(Executer.java:137)
at ij.Executer.run(Executer.java:66)
at java.lang.Thread.run(Thread.java:745)

Ok then @Darren_Thomson … If I were you, I’d notify the Bio-Formats folks. You can go to their website here… or if you want to proceed and report a bug go here. I do not see the .lof file format from Leica listed in their supported formats list.

So it seems your best bet at this point is to try contacting them directly. They also have a forum and mailing lists - so you can just take this issue directly there.

Best of luck !!

eta

Hi Darren,

did you find a solution to this problem?

I would like to open and analyze “.xlef” and “.lof” files with Fiji that are generated with a Digital Lightsheet (DLS) on the Leica TCS SP8 microscope. But no luck so far …

Thanks so much for your help!

Jakob

Hi @Jakob

No there doesn’t seem to have been movement here.
However, if I remember from our demo, the DLS makes pyradimal files (compressed) which can be opened in FIJI?

You can also download the core version of LASX free and convert your lof into an lif (here you have to open the xlef, it doesnt see the lof file).

Its our headache at the moment also. So much time wasted batch-converting files.
Please go onto Bioformats as suggested by @etadobson above and report your need for its attention (else it wont be actioned).

Best,

Darren

1 Like

Hi @Darren_Thomson,

Thank you very much for your prompt response and suggestion.

The setup over here is also via an autosave mechanism, since the files are fairly large (5 min imaging -> 20 GB). Thus, all I get are “.lof” and “.xlef”.

I then installed the free version of LAS X from Leica (http://www.leica-microsystems.com/products/microscope-software/details/product/leica-las-x-ls/). As you mentioned and as far as I know, this is currently the only available program that can read these cryptic “.lof” and “.xlef” files!

It turned out, however, that LAS X could not convert the file, around 400 GB, from “.xlef” to “.lif” because there was insufficient disk space on “C” [around 250 GB]. By default, LAS X is using a “Temp” directory on “C”. For large files this needs to be changed in “Configuration -> Memory Management -> Data Container Settings -> Folder on local Hard Disk” to something where there is sufficient space, e.g. “D”. - Perhaps this is helpful to others.

Also, I submitted a request to the Bio-Formats Forum and in the hope support for “.xlef” and “.lof” files will soon be implemented in Fiji.

Do you have a script or something similar for batch-converting .xlef files in .lif files? Or do you load them individually into LAS X and then convert one by one?

Thanks a lot!

Jakob

Hi @Jakob

Watch, if you place your temp into the D: (a HDD), then you will crash the acquisisiton if you try to transfer anything to/from the D: . We’ve just purchased an SSD to bypass this problem.
Likely you didn’t have enough space for the lif (since it will write an new file).

Sorry no batch, just manual…

Please mention this to Leica also, so that they put it up in their priorities too.
If you use IMARIS also mention your need to them too. Power in numbers!

Good luck!

Darren

Hi @Darren_Thomson,

the LAS X used for conversion is running on a server (S) that has a “C” (SSD, I guess), “D” (RAID), and “E” (RAID) drive. During acquisition LAS X is run from a computer (X) and the data is autosaved to the E drive on the server S. Thus, there are two machines, X and S, and two LAS X programes (and 5 drives: C, D, E -> Server S; A, B -> Computer X).

Do you think the problem that you mentioned could still be an issue in the setup described above?

I am in contact with Leica and Bitplane (Imaris) concerning this issue too. Power in numbers!

Thanks a lot!

Jakob

Just received the following information from Bitplane (Imaris)


[…] there is a feature request for the LOF/XLEF file format (ID 9871) that my colleagues have created from your request back in December.
For the LOF the only known workaround is to save the file as LIF in the LAS X software.
The file format is quite new and we only have some information/documentation at the moment from January according to the comments in the feature request. Given that new file format importers are quite some work and from past implementations I would guess that this is something that could be included earliest in the next major release, that is slated for end of spring / beginning of summer. However, this planning is up to our product management and development.
In the meantime you would have to use the workaround and convert the files, maybe the Bioformats (ImageJ/Fiji) group comes up with an importer in the meantime as right now they also can’t import the files.
If there is a change in its status someone from support will contact you again.

I was informed by IMARIS that there is now support for .lof files in IMARIS 9

some news on this side from bio-formats?

Not that I am aware of, unfortunately.

(Still going the long waý, i.e. xlef>lif with LASX and then import the LIF with Imaris. However, Fiji should also be able to read the LIF files - may be that helps?)

Bio-Formats has not yet been able to add support for the XLEF/LOF format however we do have a Trello card for this on our backlog (https://trello.com/c/C13JeiIu/92-add-support-for-leica-xlef-xllf-lof-files) . It is also worth taking a look at our recent blog post regarding the support of proprietary file formats by Bio-Formats - OME’s position regarding file formats

You should however be able to import the LIF files once converted.

1 Like

yes we are doing that, the problem is that we have many experiments (summing up to terabytes) saved on that format…unfortunately.

thanks I will follow the links you suggested, thanks for your job.

Emanuele

Hi Emanuele-

As @dgault pointed out, we first published our response to the ever-increasing number of proprietary file formats in 2016. An update was published recently.

It makes complete sense that you need a way to access the many TBytes of data you have collected in .lof format.

To be very blunt-- we’d prefer to spend hard-won grant funds on developing new functionality for the community. Have you contacted Leica and asked them how they plan to ensure the community can contend with yet another file format (YAFF) without resorting to indirect subsidies from government-funded community projects?

Cheers,

Jason

5 Likes

yes I totally agree with that.
Yes we are in full contact with Leica team

but honestly, we have never asked that so precisely.

It was a demo with a new instrument and unluckily the saving format was set .xlef by default and we realized that only after some acquisitions…

So it’s just a problem of these acquisitions, since next time we will save in another format for sure :wink:

thank you guys for your prompt reply,
Emanuele

2 Likes

Has there been any update regarding plugin to open .lof file?

Not really. See also this thread also:

It would be nice if a Leica representative could comment on these issues.

1 Like