Open .obj files in Fiji

fiji
3d-viewer
imagej
plugin
sciview

#1

Hello all! I’m new at Fiji.
Does anyone know if it is possible to open .obj file in Fiji? I’ve tried in 3D Viewer Plugin window --> File --> Import surfaces --> wavefront and did nothing… I’m working in a laptop. Is it possible that is just veeeery slow or I am doing something wrong? Actually it did something. It opened a new window with the file location line but it displayed nothing.


#2

Try out SciView. The Fiji update site should be in your list of available update sites. SciView can open .obj, .stl, .ply, volumes, point clouds, and maybe some other stuff that I’m forgetting.

If you have any issues, then please let us know and we’ll try to get them sorted out. SciView is still in beta, but has worked on nearly all of the systems that we’ve tested. The plan is to eventually replace 3D Viewer with SciView.


#3

Thanks!
I tried to install and it said that it has been installed but it doesn’t appear in plugins menu


#4

If it has been installed, then it might be at the bottom of the Plugins menu, or alternatively you can type “SciView” into the search box on the ImageJ toolbar.


#5

Well, now I have installed and I can access the plugin. The issue is: when I try to open a file (File -> Open…), it opens a window just similar to the window that is already opened and doesn’t let me select any file, I just get two equal windows


#6

Just to be sure, you’re using SciView’s File menu?

Menu selection


File selection
image
OBJ loaded

Alternatively, try running the scene editor:

In the above case my mesh was loaded as “Mesh”:


When you click on an object in the scene editor, it will center onto that object by default. This can help find the object if it happens to be very small or large.


#7


Yes, I just get these windows when I try to do something in sciview


#8

Aha! This is informative. I will also call in @skalarproduktraum on this, because it looks like the graphics aren’t initializing. The dark gray background covering the whole image is what indicates the issue, once the renderer successfully starts the window will contain the 3D scene.

It looks like you’re running windows, could you tell us the output of the DirectX Diagnostics (https://support.microsoft.com/en-us/help/4028644/windows-open-and-run-dxdiagexe)?

Thanks!
Kyle


#9

Yes, sure! :slight_smile: I can’t attach the file because I’m a new user but here are the first 2 pages. If you need some more information, please ask

------------------
System Information
------------------
Time of this report: 8/20/2018, 16:02:42
Machine name: PC-SARA_M
Machine Id: {0125ECA1-37C7-4B3F-9205-D286DDFEB6A7}
Operating System: Windows 10 Home 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804)
Language: Portuguese (Regional Setting: Portuguese)
System Manufacturer: ASUSTeK COMPUTER INC.
System Model: X550CC
BIOS: X550CC.217 (type: UEFI)
Processor: Intel(R) Core(TM) i7-3537U CPU @ 2.00GHz (4 CPUs), ~2.5GHz
Memory: 8192MB RAM
Available OS Memory: 8078MB RAM
Page File: 7731MB used, 1626MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Supported
DxDiag Version: 10.00.17134.0001 64bit Unicode
------------
DxDiag Notes
------------
Display Tab 1: No problems found.
Display Tab 2: No problems found.
Sound Tab 1: No problems found.
Sound Tab 2: The file anvsnddrv.sys is not digitally signed, which means that it has not been tested by Microsoft's Windows Hardware Quality Labs (WHQL). You may be able to get a WHQL logo'd driver from the hardware manufacturer.
Input Tab: No problems found.
--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)
---------------
Display Devices
---------------
Card name: Intel(R) HD Graphics 4000
Manufacturer: Intel Corporation
Chip type: Intel(R) HD Graphics Family
DAC type: Internal
Device Type: Full Device (POST)
Device Key: Enum\PCI\VEN_8086&DEV_0166&SUBSYS_124D1043&REV_09
Device Status: 0180200A [DN_DRIVER_LOADED|DN_STARTED|DN_DISABLEABLE|DN_NT_ENUMERATOR|DN_NT_DRIVER]
Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 1792 MB
Dedicated Memory: 32 MB
Shared Memory: 1760 MB
Current Mode: 1366 x 768 (32 bit) (59Hz)
HDR Support: Not Supported
Display Topology: Internal
Display Color Space: DXGI_COLOR_SPACE_RGB_FULL_G22_NONE_P709
Color Primaries: Red(0.578625,0.344250), Green(0.337414,0.571789), Blue(0.159680,0.120617), White Point(0.313977,0.329602)
Display Luminance: Min Luminance = 0.500000, Max Luminance = 270.000000, MaxFullFrameLuminance = 270.000000
Monitor Name: Generic PnP Monitor
Monitor Model: unknown
Monitor Id: LGD039F
Native Mode: 1366 x 768(p) (59.959Hz)
Output Type: Internal
Monitor Capabilities: HDR Not Supported
Display Pixel Format: DISPLAYCONFIG_PIXELFORMAT_32BPP
Advanced Color: Not Supported
Driver Name: igdumdim64.dll,igd10iumd64.dll,igd10iumd64.dll
Driver File Version: 10.18.0010.4358 (English)
Driver Version: 10.18.10.4358
DDI Version: 11.2
Feature Levels: 11_0,10_1,10_0,9_3,9_2,9_1
Driver Model: WDDM 1.3
Graphics Preemption: DMA
Compute Preemption: Thread group
Miracast: Supported
Hybrid Graphics GPU: Integrated
Power P-states: Not Supported
Virtualization: Not Supported
Block List: No Blocks
Catalog Attributes: N/A
Driver Attributes: Final Retail
Driver Date/Size: 21/12/2015 01:00:00, 11157656 bytes
WHQL Logo'd: Yes
WHQL Date Stamp: Unknown
Device Identifier: {D7B78E66-4226-11CF-F562-4732B4C2C735}
Vendor ID: 0x8086
Device ID: 0x0166
SubSys ID: 0x124D1043
Revision ID: 0x0009

#10

And I’ve just tried in another computer, also running Windows, and it did the same


#11

Hi @sarapmadeira,

it looks as if your graphics driver is really old, DXdiag reports Driver Date/Size: 21/12/2015 01:00:00, which is probably causing the issue. Could you please try updating them? Updated drivers are available at https://ark.intel.com/products/72054/Intel-Core-i7-3537U-Processor-4M-Cache-up-to-3_10-GHz#tab-blade-1-7 for your processor/integrated GPU combo.


#12

Hi @skalarproduktraum

I’ve just updated but still the same


#13

Could you additionally please post the whole text that’s shown in the Console window? Thanks!


#14

Yes, here it is! :slight_smile:


#15

@skalarproduktraum I believe you caught it in our other conversation. It looks like a path issue.

@sarapmadeira can you try this:

Go into your Fiji.app/jars and find a folder “win64” in there you will see “spirvcrossj-0.4.1-natives-windows.jar”
Please move this file from “Fiji.app/jars/win64” to “Fiji.app/jars”
Test to see if SciView opens for you

Thank you!


#16

I did it. Now it does not show the console but it continues to open new windows when I try to run any command and so I still can’t open files.


#17

And the window is dark gray everywhere (e.g. it looks like your previous screenshot)?


#18

Yes, just like in the previous screenshot