Open CV7000 image with Bio-Formats problem

Hi,
I was using the Bio-Formats import function in a macro to open images from the Yokogawa CV7000 microscope (for special reasons I needed this import rather than the normal open command).
Now I found that Bio-Formats imports the image in a strange/wrong way. Intensities are messed up (see attached screenshot).
CV7000image_openVsBioformats
If I open the image normally e.g. vial drag and drop the image looks ok.
Maybe this is related to the new release!?
I also attached the image as .zip here.
190318-dyes-60x_C07_T0001F009L01A04Z01C04.zip (4.8 MB)

Thanks,
Martin

1 Like

Hi Martin, are you using the latest release (either 6.0.0 or 6.0.1 should have the CV7000 reader)? Using the sample file provided and 6.0.1 I am not reproducing the issue you are seeing and the image looks to be correct. Opening the tiff file on its own should use a standard tiff reader, is there a WPI file in the directory? Opening that file will use the CV7000 reader.

1 Like

Hi,

I am using the latest version (bio-formats_plugins-6.0.1.jar).

As I said, the Bio-Format import of a single .tif image was working in the past (e.g. like half a year ago, with this type of macro code:
run(“Bio-Formats”, “open=[” + currentFile + “] autoscale color_mode=Default view=[Standard ImageJ] stack_order=XYCZT”); ).

I didnt know that one suppose to use the .wpi file instead. Ok, that works fine, I also figured out how to open a single image/channel.

Great that the meta data (like image size) is read correctly! With opening the .tif directly with Bio-Formats import or with standard tiff reader the metadata was always messed up (just look on the image sizes of the screenshots above, inches and microns, the view field in reality is 276x233 microns). Now this looks fine:
image

However, I wouldnt know how to open a single image using the macro language (the recoder just recorded the single line you see in the screen shot).

Anyway, it looks like also something changed in the standard tiff reader. My task to open some files, calculate and generate new images and save these as .tif files, that then are used by the CV7000 microscope software for illumination correction was only working in the past, when I was using the Bio-Formats import (Standard tiff reader => CV7000 software could not read .tif files). Now it also works with the standard tiff reader. Great!

Thanks for clarification!

Martin

Does it record correctly when you go via Plugins > Bio-Formats > Bio-Formats Importer to open the .wpi file (instead of drag-and-drop)?

Do you mean you used the tiff writer to save files that are then read by the CV7000 software?

Oh, yes, this was my mistake. It does record correctly when .wpi is opened via the menu (Plugins > Bio-Formats > Importer or File > Import > Bio-Formats). Drag & drop doesnt record.

Yes, I was using the tiff writer to write .tif for the CV7000 software. I think it is worth mentioning here, that I had to use the byte order to little-Endian (Intel) to make it work for the CV7000 software.
macro (e.g.): run(“Input/Output…”, “jpeg=95 gif=-1 file=.txt save copy_column copy_row save_column save_row”);
manual: Edit > Options > Input/output

1 Like