Only Resize works while Processing as 3D, error for the rest



I have been trying to get the 3D pipeline to work for my dataset which is a de-convolved tiff stack on one channel(single tiff). However only ‘Rescale Intensity’ works, the other module give me an error as below


‘Error while processing ‘Module name’: Do you want to stop processing?’

May you can tell me what the problem could be or does it not support such a file?


Can you upload the pipeline and image so we can attempt to verify? Thanks.


Thankyou for your reply!

This is the pipeline, same as the one for the monolayer.
For3Dsegmentation.cppipe (7.5 KB)

The de-convolved file is here:


I tried this pipeline out on your image and it worked fine on my system. Could you tell us about the computer you are running it on?


Hey Laura, thanks for trying it out. I am trying this on a Windows 10 64-bit OS, 16GB RAM.
Which computer are you working on (not sure if this is the issue, because the 2D segmentation works fine for the same stack, its only when I process as 3D)? Also, did the pipeline finish completely? Please let me know if you have an idea what else I can try!



I am on a MacBook Pro with High Sierra - also 16GB RAM. The pipeline did finish completely although first I had some memory issues so I cropped much tighter around your embryo(??) and also took I think around 200 redundant z slices out at each side to make the image smaller.

Are you using the stable release of 3.0.0? You could always try building from source.

I don’t really have any other ideas but maybe someone else will!


Thanks a lot! will try it out…


@lmurphy Cutting the slices down did indeed solve the problem! However, this is only one time point! :-. The 2D stacks of approx. 30 timepoint(2077 slices) could be processed just fine without running into memory issues. Not sure why while processing as 3D this is an issue, since it also looks at them slice by slice.




Even though the Resize module is resizing the slices only in X and Y, it is loading the whole stack if you’re analyzing in 3D, which explains your memory error. Hope that clarifies it!