OMERO web wont start

I am running OMERO 5.5.1 on Ubuntu 16.4 with the following components:

Commands: java -version 1.8.0 (/usr/bin/java)
Commands: python -V 2.7.12 (/usr/bin/python)
Commands: icegridnode --version 3.6.5 (/usr/bin/icegridnode)
Commands: icegridadmin --version 3.6.5 (/usr/bin/icegridadmin)
Commands: psql --version 9.6.15 (/usr/bin/psql)
Commands: openssl version 1.1.111 (/usr/local/bin/openssl – 2 others)

Server: icegridnode running
Server: Blitz-0 active (pid = 3893, enabled)
Server: DropBox active (pid = 3905, enabled)
Server: FileServer active (pid = 3919, enabled)
Server: Indexer-0 active (pid = 3909, enabled)
Server: MonitorServer active (pid = 3907, enabled)
Server: OMERO.Glacier2 active (pid = 3914, enabled)
Server: OMERO.IceStorm active (pid = 3917, enabled)
Server: PixelData-0 active (pid = 3910, enabled)
Server: Processor-0 active (pid = 3936, enabled)
Server: Tables-0 active (pid = 3938, enabled)
Server: TestDropBox inactive (enabled)

I have just successfully installed omero-ivewer 0.8.0, but when I try to start the OMERO web component I get the following error:

omero@OMERO:~/OMERO.server$ bin/omero web start
Traceback (most recent call last):
File “”, line 56, in
File “/usr/local/lib/python2.7/dist-packages/django/core/management/”, line 354, in execute_from_command_line
File “/usr/local/lib/python2.7/dist-packages/django/core/management/”, line 328, in execute
File “/usr/local/lib/python2.7/dist-packages/django/”, line 18, in setup
File “/usr/local/lib/python2.7/dist-packages/django/apps/”, line 89, in populate
“duplicates: %s” % app_config.label)
django.core.exceptions.ImproperlyConfigured: Application labels aren’t unique, duplicates: iviewer

On the web side I get the following error when trying to navigate to the OMERO login page:

502 Bad Gateway

nginx/1.10.3 (Ubuntu)

I’m new to the whole OMERO and OME environment so I do not know where to go to resolve the issue and how to decode the output logs. Any thoughts or suggestions on a solution. Thanks.

Hi (and welcome to the OME community)

Can you check whether you’ve added iviewer to your omero.web.apps multiple times?

$ bin/omero config get omero.web.apps

If so, try removing the duplicate:

$ bin/omero config remove omero.web.apps '"omero_iviewer"'

Hope that helps,
Let us know…

Hi Will,

Thanks for the information that was really helpful. That solved my issue on that front, I had 2 entries for the iviewer and the mapr apps. However when I did a Omero admin start and a Omero web start I get the follwing error when I try to access the OMERO login web page:

Internal Server Error

I have attached the log for the OMEROweb app and it looks like there is an unsupported version of OME that I have installed. Looks like a conflict with django.

Any assistance would be greatly appreciated. Thanks!


OMEROweb.txt (171.3 KB)

Hi Alex,

It looks like that exception is coming from omero-marshal 5.4.

Can you check what version of omero-marshal you have

pip freeze

and upgrade to the latest version (0.61)



Hi Will,

Thanks for the direction, I have omero marshal 0.5.3 installed. I checked the upgrade files and I can’t seem to get them installed. I get the error that the files can’t be found even if I download them directly to the server.

Are there any specific commands that are needed to get that marshal component upgraded using the .zip file? Thanks.


Hi Alex,

You shouldn’t need any zip file.

$ pip freeze | grep marshal

$ pip install -U omero-marshal
Successfully installed omero-marshal-0.6.1

Should be all you need.


omero@omero:~>sudo pip install omero-marshal Successfully installed omero-marshal-0.6.1 omero@omero:~>sudo systemctl restart omero-web.service

omero@omero:~$>sudo systemctl status omero-web.service
● omero-web.service - OMERO.web
Loaded: loaded (/etc/systemd/system/omero-web.service; enabled; vendor preset: disabled)
Active: active (running) since jeu. 2019-09-26 16:40:28 CEST; 1min 15s ago
Process: 22054 ExecStop=/home/omero/omerowebvenv/bin/python /home/omero/ web stop (code=exited, status=0/SUCCESS)
Process: 22063 ExecStart=/home/omero/omerowebvenv/bin/python /home/omero/ web start (code=exited, status=0/SUCCESS)
Main PID: 22106 (gunicorn)
CGroup: /system.slice/omero-web.service
├─22106 /home/omero/omerowebvenv/bin/python2 /home/omero/omerowebvenv/bin/gunicorn -D -p /home/omero/ --bind…
├─22111 /home/omero/omerowebvenv/bin/python2 /home/omero/omerowebvenv/bin/gunicorn -D -p /home/omero/ --bind…
├─22114 /home/omero/omerowebvenv/bin/python2 /home/omero/omerowebvenv/bin/gunicorn -D -p /home/omero/ --bind…
├─22117 /home/omero/omerowebvenv/bin/python2 /home/omero/omerowebvenv/bin/gunicorn -D -p /home/omero/ --bind…
├─22122 /home/omero/omerowebvenv/bin/python2 /home/omero/omerowebvenv/bin/gunicorn -D -p /home/omero/ --bind…
└─22131 /home/omero/omerowebvenv/bin/python2 /home/omero/omerowebvenv/bin/gunicorn -D -p /home/omero/ --bind…

sept. 26 16:40:24 systemd[1]: Starting OMERO.web…
sept. 26 16:40:26 python[22063]: Post-processed ‘omeroweb.viewer.min.css’ as ‘omeroweb.viewer.min.css’
sept. 26 16:40:26 python[22063]: Post-processed ‘omeroweb.viewer.min.js’ as ‘omeroweb.viewer.min.js’
sept. 26 16:40:26 python[22063]: 0 static files copied to ‘/home/omero/’, 706 unmodif…cessed.
sept. 26 16:40:27 python[22063]: Clearing expired sessions. This may take some time… [OK]
sept. 26 16:40:27 python[22063]: Starting OMERO.web… [OK]
sept. 26 16:40:27 systemd[1]: Can’t open PID file /home/omero/ (yet?) after start: No such file o…rectory
sept. 26 16:40:28 systemd[1]: Started OMERO.web.
Hint: Some lines were ellipsized, use -l to show in full.
omero@omero:~> web status OMERO.web status... [RUNNING] (PID 22106) omero@omero:~>tail
DropBox.log master.err MonitorServer.log OMEROweb.log Tables-0.log
FileServer.log master.out OMEROweb.lock Processor-0.log
from omeroweb.webgateway import views as webgateway_views
File “/home/omero/”, line 39, in
from marshal import imageMarshal, shapeMarshal, rgb_int2rgba
File “/home/omero/”, line 30, in
from omero_marshal import get_encoder
File “/home/omero/omerowebvenv/lib/python2.7/site-packages/omero_marshal/”, line 62, in
SCHEMA_VERSION = get_schema_version(omero_version)
File “/home/omero/omerowebvenv/lib/python2.7/site-packages/omero_marshal/”, line 60, in get_schema_version
raise Exception("Unsupported OMERO version: " + version)
Exception: Unsupported OMERO version: 5.5.1-ice36-b122

Hi Philippe,
I think that when you’re installing omero-marshal you need to be sure that you are within your omerowebvenv virtual env.

source /home/omero/omerowebvenv/bin/activate
pip install -U omero-marshal

The stack trace you’re getting doesn’t correspond to the line numbers in omero-marshal 0.6.1 (line 60), but fits with omero-marshal 0.5.2.

Hope that helps,


Hi Will,
You’re right !!!
And I discover that /home/omerowenenv belonged to root ??? I think it’s wrong so I change to omero user.


3 posts were split to a new topic: OMERO.web - intermittent 404 pages

Hi Will,

Thanks, that solved my issue!! I can now access my OME environment from the web portal.