Omero.web installation issue

I would like to use omero-figure and, for that, I will need to install omero-web. Unfortunately, I couldn’t install it on my Mac or on a Windows 7 computer. I have tried to follow the most simple instructions (in comand prompt) as well as the video on YouTube (in conda) but, regardless of the way I try to do it, I seem to have the same error, I believe.

To make it easier to follow my issue, I followed this video step-by-step omero-web developer install - YouTube

And after going through half of the video (after going to Visual Code, that’s where I started to have problems…)

This is part of the error that I get after I run % pip install -e .on visual studio code:

→ this is where the code gets stuck at first:

Building wheels for collected packages: zeroc-ice
  Building wheel for zeroc-ice (setup.py) ... - 

…after this, the code runs but it gives me the following error

...
       ^
  2 errors generated.
  error: command '/usr/bin/gcc' failed with exit code 1
  ----------------------------------------
  ERROR: Failed building wheel for zeroc-ice
  Running setup.py clean for zeroc-ice
Failed to build zeroc-ice
Installing collected packages: zeroc-ice, pytz, omero-py, omero-marshal, gunicorn, django-pipeline, Django, omero-web
  Attempting uninstall: zeroc-ice
    Found existing installation: zeroc-ice 3.7.5
    Uninstalling zeroc-ice-3.7.5:
      Successfully uninstalled zeroc-ice-3.7.5
    Running setup.py install for zeroc-ice ... error
    ERROR: Command errored out with exit status 1:

......

ERROR: Command errored out with exit status 1: /Library/Frameworks/Python.framework/Versions/3.9/bin/python3.9 
....

I have installed the requirements (ICE included) but I need having the same error…

What could be causing this issue?

Many thanks!

Hi @Debora_Serrenho,

do you mind if I convert this to a public topic so others can follow along?

Please do! Thanks

The installation is trying to compile the Python support for Ice. What platform is this? We might have pre-compiled wheels that you can use. See Open Microscopy Environment · GitHub, e.g.

pip install https://github.com/ome/zeroc-ice-py-centos7/releases/download/0.2.1/zeroc_ice-3.6.5-cp36-cp36m-linux_x86_64.whl

If not, then I’d suggest trying conda: http://anaconda.org/ome/omero-py

All the best,
~Josh

I solved this problem! It was a simple thing actually. I was having troubles setting the environment variable!

I was using conda but, since I am not familiar with this sort of things, I was having an hard time setting the environment variable on my Mac.
Thanks for the help anyway. I would ask whether this section of the installation instructions could be clarified in git-hub. It could help other people in a similar situation to mine. Regardless of that, thanks for the help!