Omero.Web Error: Server is not responding, please contact administrator

Hello,

I’m alway on the road to update OMERO 5.4.0 to 5.5.1. This time i failed to connect via OMERO.web.

When trying to log in i got "Error: Server is not responding, please contact administrator. " ( I’m the administrator… oh… well… )

Here’s the error in OMERO.web logfile :

2020-06-12 08:56:23,609  INFO [                           omero.gateway] (proc.03481) connect():2228 Failed to create session.
2020-06-12 08:56:23,612 WARNI [                      omeroweb.connector] (proc.03481) create_guest_connection():190 Cannot create a guest connection.
2020-06-12 08:56:23,614 WARNI [                            omero.client] (proc.03481) __del__():440 ..Ignoring error in client.__del__:<class 'Ice.ProtocolException'>
2020-06-12 08:56:23,615  INFO [                           omero.gateway] (proc.03481) close():1952 closed connection (uuid=None)

The Omero.server is listening :

kansas-new:/home/omero/apps/OMERO/OMERO.server# netstat -an | grep 4064
tcp6       0      0 :::4064                 :::*                    LISTEN     

I had no idea where to search for this problem, so any help would great.

O.

Ok, that was a cipher problem. Made that :

sudo -u omero bin/omero config set omero.glacier2.IceSSL.Ciphers HIGH:ADH:@SECLEVEL=0

And omero.web connect back to Omero.server.

I thought this was fine, but in the web interface i had the explore Pane stuck in “loading” state. Kill all browsers, clear cache and restart a browser. All is ok.

1 Like