OMERO.server installation help please

sudo bash install.txt (54.9 KB)

Hi,

Our department is attempting to install OMERO.server but unfortunately, we don’t have much technical expertise. We’ve installed Ubuntu 18.04 along with the GNOME desktop.

We downloaded the installation script from GitHub and executed “install_ubuntu1804.sh” by opening a Terminal session within GNOME.

Unfortunately, we see the error below and the script stops. The entire installation log has been attached.

step04_all_omero.sh: Permission denied

Any help would be appreciated.

Thank you!

Hi @bauyoung. Welcome to image.sc!

It looks like the permissions for the bash script don’t allow the omero-server user to read it. You can either change ownership with chown omero-server step04_all_omero.sh or make it readable with chmod a+r step04_all_omero.sh.

~Josh

1 Like

Thanks for the welcome and quick reply, Josh!

I’ve tried both commands and the error persists. Is there anything else I should try?

+ su - omero-server -c 'OMEROVER=latest ICEVER=ice36 bash -eux step04_all_omero.sh'
bash: step04_all_omero.sh: Permission denied
[root@LAB-OMERO linux] 00:40:25
# chown omero-server step04_all_omero.sh
[root@LAB-OMERO linux] 00:41:10
# su - omero-server -c 'OMEROVER=latest ICEVER=ice36 bash -eux step04_all_omero.sh'
bash: step04_all_omero.sh: Permission denied
[root@LAB-OMERO linux] 00:41:46
# chmod a+r step04_all_omero.sh
[root@LAB-OMERO linux] 00:42:15
# su - omero-server -c 'OMEROVER=latest ICEVER=ice36 bash -eux step04_all_omero.sh'
bash: step04_all_omero.sh: Permission denied

Thanks!

Hi @bauyoung

Did you try to follow the step-by-step instructions [1] instead of running the script?
Some steps are done as an admin some as the omero-user This could help us identifying where the problem is.

Cheers

Jean-marie
[1] https://docs.openmicroscopy.org/omero/5.6.3/sysadmins/unix/server-ubuntu1804-ice36.html

Hi @j.burel,

My first attempt at OMERO.server installation was following the step-by-step instructions. However, I wasn’t sure how to create the settings.env file or how to “load” those variables. If I copy settings.env to /tmp will the variables be loaded automatically?

Thank you,

Brian

You can either copy the values in the terminal i.e. export ... where you are running the commands or
“source” the settings.env e.g. . /tmp/settings.env (if settings is in /tmp) so that the environment variables are available to the following commands.

Cheers
Jmarie

I followed the step-by-step instructions, beginning by copying the settings.env file to /tmp/. Next, I ran the following commands to source settings.env.


[root@LAB-OMERO ~] 05:47:51
# #!/usr/bin/env bash
[root@LAB-OMERO ~] 05:55:23
# cd ~/tmp
bash: cd: /root/tmp: No such file or directory
[root@LAB-OMERO ~] 05:55:37
# dir
Desktop  Documents  Downloads  Music  Pictures    Public    Templates  Videos
[root@LAB-OMERO ~] 05:56:00
# source . /tmp/settings.env
bash: source: .: is a directory
[root@LAB-OMERO ~] 05:56:22
# source ./tmp/settings.env
bash: ./tmp/settings.env: No such file or directory
[root@LAB-OMERO ~] 05:56:38
# bash /tmp/settings.env
[root@LAB-OMERO ~] 05:56:51
# source /tmp/settings.env

However, I’m now stuck at the Configuring OMERO.server step. I tried switching to the omero-server user, but once that’s done, I’m not sure how to source the settings.env file again.

[root@LAB-OMERO server] 06:07:01
# su - omero-server
$ omero config set omero.data.dir "$OMERO_DATA_DIR"
omero config set omero.db.name "$OMERO_DB_NAME"
omero config set omero.db.user "$OMERO_DB_USER"
omero config set omero.db.pass "$OMERO_DB_PASS"
omero db script -f $OMERODIR/db.sql --password "$OMERO_ROOT_PASS"
psql -h localhost -U "$OMERO_DB_USER" "$OMERO_DB_NAME" < $OMERODIR/db.sql-su: 1: omero: not found
$ -su: 2: omero: not found
$ -su: 3: omero: not found
$ -su: 4: omero: not found
$ -su: 5: omero: not found
$ omero config set omero.data.dir "$OMERO_DATA_DIR"
-su: 6: cannot open /db.sqlomero: No such file
$ source . /tmp/settings.env
-su: 7: source: not found
$ source ./tmp/settings.env
-su: 8: source: not found
$ source /tmp/settings.env
-su: 9: source: not found
$ dir
examples.desktop
$ dir             
examples.desktop  settings.env
$ source settings.env
-su: 12: source: not found
$ source /home/settings.env
-su: 13: source: not found
$ source ./home/settings.env
-su: 14: source: not found
$ dir
examples.desktop  settings.env
$ dir desktop
dir: cannot access 'desktop': No such file or directory
$ cd examples.desktop
-su: 17: cd: can't cd to examples.desktop
$ source /settings.env
-su: 18: source: not found
$ source /tmp/settings.env
-su: 19: source: not found
$ source ./tmp/settings.env
-su: 20: source: not found
$ source /tmp/settings.env
-su: 21: source: not found
$ export OMERO_DB_USER=db_user
$ export OMERO_DB_PASS=db_password
$ export OMERO_DB_NAME=omero_database
$ export OMERO_ROOT_PASS=omero_root_password
$ export OMERO_DATA_DIR=/OMERO
$ export OMERO_DB_USER OMERO_DB_PASS OMERO_DB_NAME OMERO_ROOT_PASS OMERO_DATA_DIR
$ export PGPASSWORD="$OMERO_DB_PASS"
$ export OMERODIR=/opt/omero/server/OMERO.server
$ VENV_SERVER=/opt/omero/server/venv3
$ export VENV_SERVER=/opt/omero/server/venv3
$ export PATH=$VENV_SERVER/bin:$PATH
$ omero config set omero.data.dir "$OMERO_DATA_DIR"
omero config set omero.db.name "$OMERO_DB_NAME"
omero config set omero.db.user "$OMERO_DB_USER"
omero config set omero.db.pass "$OMERO_DB_PASS"
omero db script -f $OMERODIR/db.sql --password "$OMERO_ROOT_PASS"
psql -h localhost -U "$OMERO_DB_USER" "$OMERO_DB_NAME" < $OMERODIR/db.sql-su: 33: omero: Permission denied
$ -su: 34: omero: Permission denied
$ -su: 35: omero: Permission denied
$ -su: 36: omero: Permission denied
$ -su: 37: omero: Permission denied
$ omero config set omero.data.dir "$OMERO_DATA_DIR"
-su: 38: cannot open /opt/omero/server/OMERO.server/db.sqlomero: Permission denied
$

The full output is attached, but the last two pages is where the problem shows up after I run the command su - omero-server.

Thanks again!

Hi @bauyoung

if you have put the file settings.env in the /tmp folder the command is
source /tmp/settings.env or . /tmp/settings.env (note the space between the dot and /tmp/settings.env).

Are you installing to evaluate if OMERO will be a solution for you?
if this is the case, it might be easier to use our demo server, you will just need our Desktop client to import images and use the web client for the exploration [1]. You can sign in for a free account at [2]

If you are not too comfortable with Linux commands, we also have available Docker images built with OMERO server, OMERO web.

Cheers

Jmarie

[1] https://www.openmicroscopy.org/omero/
[2] https://www.openmicroscopy.org/explore/

Hi @j.burel,

We’ve tried the demo server and it works well! But we wanted to see how it works on a local server (the upload speeds) as well user account administration.

For the Docker images, do you know if they work with RedHat 7? We don’t have access to CentOS images for our virtual machines.

Thanks,

Brian

Hi Brian

OMERO offers you the ability to create your own user/group but also to user LDAP authentication https://docs.openmicroscopy.org/omero/5.6.3/sysadmins/server-ldap.html

If you have Docker installed, you should be able to run the images.

Cheers

Jmarie