Omero connection faults from CP2.2 and CP3

cellprofiler
omero
import
filelist
cp22
cp3
loadimages

#1

I’ve been trying to import a file list of omero images but am getting errors in CP. The omero database is v5.4.0 (ice36). In CP2.2.0 I can log onto the server successfully, but then it gives me a ‘failed to open file, “omero:iid=104”’ when I try to show the image. In CP3.0.0 when it asks to log into the server I just get a failed to connect to server error in the ‘Log into Omero’ popup. I’m running both versions of CP from the same mac (OS v 10.12.6). I did look here


which suggests a few jar files that should eb identical for both CP and Omero Insight. The jars exist in Omero Insight, but not in either of my CP installs. It is not clear where they should go in 2.2 or CP3 on a amc install.

So, is it just these I’m missing? And if so, where do they go? I have tried adding them to resources/lib/pyhton2.7/javabridge/jars in both CP2.2 and CP3, and neither makes any difference.

And what has gone wrong with CP3 for it to fail to connect? (of note, the fail to connect is instantaneous, it isn’t even trying, and yes, I’ve got the settings correct and have retried several times).

Any help gratefully received- I would love to get Omero to link with CellProfiler! I have access to a linux box and could try CP from there if it would help?

Cheers,

Glyn


#2

As an update, I found this page https://www.openmicroscopy.org/community/viewtopic.php?f=4&t=7821&p=15817#p15817 and tried going to metadata to connect. This still gave me the error, but I at least got some error info (see below). Also, I tried this using CP3 on a win7x64 box with the same result.

Traceback (most recent call last):
File “/Applications/CellProfiler.app/Contents/Resources/lib/python2.7/cellprofiler/gui/moduleview.py”, line 1134, in callback
File “/Applications/CellProfiler.app/Contents/Resources/lib/python2.7/cellprofiler/gui/moduleview.py”, line 2064, in __on_do_something
File “/Applications/CellProfiler.app/Contents/Resources/lib/python2.7/cellprofiler/settings.py”, line 1934, in on_event_fired
File “/Applications/CellProfiler.app/Contents/Resources/lib/python2.7/cellprofiler/modules/metadata.py”, line 483, in
File “/Applications/CellProfiler.app/Contents/Resources/lib/python2.7/cellprofiler/modules/metadata.py”, line 863, in do_update_metadata
File “bioformats/formatreader.pyc”, line 985, in get_omexml_metadata
File “/Applications/CellProfiler.app/Contents/Resources/lib/python2.7/javabridge/jutil.py”, line 392, in run_script
JavaException


#3

Hi Glyn,

connecting to OMERO newer than 5.2 is currently broken. OME / Glencoe people are having a fix in the works, I can probably look up the corresponding Github tickets tomorrow. If you prefer to go looking yourself, check out the issues of the prokaryote repository.

Cheers
Niko


#4

Hi, @ehrenfeu. Chris sent us a patch that I merged into prokaryote and bumped the version. Would you mind testing to see whether it resolves the problem?


#5

Hi @agoodman, I can only confirm what lguerard wrote in the github ticket (we are sharing the same office…) - the patch is fixing the problem for us. Tested on windows 7 and Ubuntu 16.04 (or latest mint to be more precise…)

Cheers
Niko


#6

Sounds promising. However, either my understanding of github or macs has failed me. I followed:


using git clone https://github.com/CellProfiler/prokaryote.git $HOME/CellProfiler
and it says it has installed prokaryote successfully. However, if I try to run it the command is not found.
I suspect my problem is I got lost with the post from Chris Allen here:
https://github.com/CellProfiler/prokaryote/issues/33
Specifically, he says
’You will then need to Git clone this prokaryote repository somewhere, check out master, build the JAR dependency and apply the dependency to your PYTHONPATH. For example:

pip uninstall prokaryote
git checkout master
mvn clean
mvn
pip install -U -e .’

Firstly, I don’t know which variables I need to set in pythonpath (or how exactly). Secondly I’m confused why I would uninstall prokaryote after just installing. Thirdly, the command mvn or mvn3 gives me ‘command not found’ error.

So I’m currently stuck. I’d be happy to test it works- certainly sounds like it does from what @ehrenfeu says. My apologies for my ineptitude when it comes to understanding installations at the command line. My poor knowledge for environment variables and what is and is not setup by the install doesn’t help either.

Any more verbose explanations of what you think I’ve done wrong here would help.

Thanks,

Glyn.


#7

Hi, @Glyn_Nelson! pip install prokaryote should work now.