Omero config set omero.data.dir "$OMERO_DATA_DIR"

Following error is displayed after executing the command post (su - omero-server)

[omero-server@localhost ~] export OMERODIR=/opt/omero/server/OMERO.server [omero-server@localhost ~] omero config set omero.data.dir “$OMERO_DATA_DIR”
-bash: omero: command not found

It looks like you may have not activated the appropriate virtual environment.

The virtual environment is setting in settings.env file. The same has been set .bash_profile in /home/omero-server. Even tried executing the commands directly from the prompt.

as root:
Copy the file settings.env to /home/omero-server/
Change owner to omero-server
set it executable to the owner

as su - omero-server
. ~/settings.env

then the omero command works

Thanks Miguelle. That sorted out the issue. Installation completed successfully. Thanks once again. Extremely sorry for not having written earlier.

I think the root cause of the problem was the missing space between export and OMERODIR.
But glad that putting everything in settings.env solved the problem.