OMERO 5.6 upgrade failed

Hi guys,

I’m having some serious trouble with the upgrade to 5.6.0

I performed the usual upgrade procedure for the server (Backup DB, update required packages, download latest version, unzip, update shortcut). However, the server wouldn’t start and I noticed that there is no more bin directory. Is this correct?
In order not to break anything, I reverted everything back to 5.5.1 and got the old version running again.
Could you give me some assistance with the upgrade (the upgrade guide didn’t really help).

As for the web server, I think something went really wrong during the upgrade and I think I managed to produce a deadly mix of python 2.7 and 3.5… I think I will reinstall the web server from scratch and see how that works out.

Thanks,
Gebhard

Hi Gebhard

Sorry to hear that you are having trouble upgrading
for 5.6 we continue the “decoupling” work started in 5.5.
This time we focused on Python packages.
As you noticed there is no more bin directory
We recommend to install omero-py and omero-web in Python virtual environments.
You need to set a new variable OMERODIR pointing to where the OMERO.server is unzipped.
Following one the installation guides https://docs.openmicroscopy.org/omero/5.6.0/sysadmins/unix/server-installation.html should help you going over the various steps
. You can probably skip some sections

We will review the upgrade page to make sure it is clearer

Cheers

Jmarie

Hi @GebhardS

What operating system are you using? We have production Ansible playbooks for CentOS 7 which we use for all our OME deployments. We’d like to add support for a limited number of other OSes such as Ubuntu in our Ansible roles, and to help us prioritise it’d be useful to know if this is something you (and others on this forum) would want to use, and what OS.

Hi @manics,

we’re currently using Ubuntu 16.4 LTS.

As far as our OMERO-web is concerned, we’ve scheduled a clean reinstall in two weeks and we are planning to run it on Ubuntu 18.4 LTS.

Hi @GebhardS

If you follow the link posted previously you should find step-by-step installation guide for both Ubuntu 16.04 (web/server) and 18.04 (web/server).
Ubuntu 16.04 comes with Python 3.5. We have not done in depth testing with Python 3.5 but we do not expect major issues.

Please let us know if you find any issues.

Jmarie

Thanks @j.burel,

I will try the update of the OMERO server again next week, and let you know about the status.
The web server will be done from scratch, but a little later, since it is not that critical.

Thank you for your feedbad!

just to clarify, do I have to install omero.py (pip install omero.py) to run the omero server (not web)?

Yes, pip install omero-py is needed for both OMERO.server and OMERO.web.

OK, after some hickups with ice and an old environment variable omero started again.
however, i cannot login anymore…

OMERO.insight just tells me that hte login failed
and CLI tells me this:

InternalException: Failed to connect: exception ::Ice::PluginInitializationException
{
    reason = IceSSL: unable to set ciphers using `HIGH:ADH:@SECLEVEL=0':
invalid command
}

any ideas?

Let’s check some things. For both the server and the machine you’re running Insight on,

  • Are they both Ubuntu 16.04 LTS?
  • Which version of OpenSSL is installed? (openssl version)
  • Is there an /etc/ssl/openssl.cnf file? Does it set MinProtocol or CipherString? Just attach it here if you like.
  • What does openssl ciphers HIGH:ADH:@SECLEVEL=0 say?

The server is Ubuntu 18.04 LTS, Insight is running on windows (i tried 7, and 10)
OpenSSL is version OpenSSL 1.1.1 11 Sep 2018
I couldn’t find MinProtocol or CipherString in /etc/ssl/openssl.cnf (file is attached)openssl.cnf.txt (10.7 KB)
openssl ciphers HIGH:ADH:@SECLEVEL=0 gave me a long string encryption/hash algorithms (I guess)

Hi Gebhard

Will you be able to run insight on an other OS e.g. Mac or Linux? We are trying to find out the source of the problem. We have not been able to reproduce the problem

Thanks
Jmarie

It’s the same.
I got a few “please check your login/password and try again later” messages and then it changed to this:
grafik

I tried with both ports, 4063 & 4064.

Hi @GebhardS
We’re still investigating, you’re not the only one who’s had problems: (OMERO) IceSSL: unable to set ciphers

Hi Guys,

we’re still having the login problem. Is there a solution yet, or will this be fixed with the update tomorrow?
A short heads-up would be nice.

Cheers,
Gebhard

None of us have been able to reproduce the problems you’re experiencing. However we did discover a separate SSL related problem on Ubuntu 18.04. In testing we were able to workaround it by creating a set of self-signed certificates, which means it’s possible to use stronger encryption algorithms instead of the default anonymous ones. Since certificate verification is disabled by default self-signed certificates are OK.

We have an OMERO plugin to help with configuration

Could you give that a go and let us know if it also fixes your problem?

Server is running again!
I played through the entire installation process by hand, to make sure i didn’t forget anything, then I installed omero-certificates and now it works.