Nuclei identification parameter help

Dear Community

This is my first post on this board. I have been using cellprofiler for several month now, I have a fairly specific question regarding nuclei identification. I have a set of images consisting of cell that have been immunostained for a nuclei specific protein (see attached image), I need to calculate the area of the nuclei based on this signal. I am using the attached pipelines to generate this data.

I am having the following problem. If the identification parameter of object size is set to be between 10,40 pixels, the program seems to break up the nuclei into small pieces. If the parameter is set as 20,60 pixels (very close to what the measured size is) the program does not identify many nuclei, and tends to merge the ones it does identify. I tried running several different identification algorithms, and no luck, OTSU adaptive seems to be the best. What would be the recommended setting for this type of images? Would it be possible to train the software to recognize my objects? Should I do more image processing to improve my results?

Thank You
Gene



Nuclei_id_2060_w_figsPIPE.mat (956 Bytes)
Nuclei_id_1040_w_figsPIPE.mat (956 Bytes)

Hi Gene,

I believe part of the reason you are getting these results is that the settings for the smoothing filter size and the maxima separation distance (below the declumping methods) are both set to ‘Automatic’. This means that they are estimated from the lower size criterion you’ve entered, and hence, the results are different between the two size cases you’ve considered.

It seems that the 10,40 range is capturing most of what you want, but you might want to bump the higher limit from 40 to 60 to get the rest. Also, you may want to manual adjust the smoothing filter and maxima separation distance settings to something more appropriate. The amount of smoothing (filter size ~ 7) seems to be OK, so you may want to hard-set at this value. However, you are seeing over-segmentation which means that the maxima separation distance (currently set to ~7) is too low. Something in the range of 15 might work better; you’ll need to experiment to see what works best (or at least, better).

Hope this helps!
-Mark