Not running in parallel unless using groups

I’m running CellProfiler 2.1.1 on Windows, and have definitely had it running in parallel in the past. However, on a different desktop it’s processing the images one by one. Looking in task manager only one core is being used, and the number of images processed is increasing one-by-one. Although grouping my images still works, and has them running in parallel.

Is there a way round this? I’ve got the maximum no. of workers set on 16 (default), and can’t find any other options in the settings that I might have accidently changed. The CPU usage flashes to 100% (all cores) when I first start the analysis, but then drops back down to ~10% immediately.

Thanks,
Scott.

Hi Scott,

Is this still an issue? So in Preferences, you have “Maximum number of workers” set to some value? Would you try and reduce this to something above 1, but less than the number of cores?

Do you have any ‘unusual’ modules like RunImageJ? Do you have a large number of images? DO you have enough memory allocated for Java in Preferences?

Feel free to post your pipeline of still an issue.
David

Hi David,

Still not solved this, I’ve tried:

  • Running fewer workers, 2,4,8 workers, still running a single worker.

  • Increasing Java memory upto 2056mb

  • No unusual modules that I can tell.

  • There are 1440 image sets, not sure if this counts as a large number.

I’ve attached a pipeline (updated).

Many thanks,
Scott.
T47D.cppipe (27.3 KB)

Hi,

Thanks for this, finally returning to it. Hmm, I don’t see anything obviously amiss. Since I don’t have your image list, I can only guess at what the Metadata and Groups modules output looks like. But I take a close look at what the Groups module output table looks like in the settings. Can you send a screenshot? Each group will get an independent worker and maybe this is not getting set properly, or the metadata is not getting extracted properly. I do not know why this would happen on one computer and not another though.

David

Hi David,

I have attached a screenshot of the Metadata output table.

This seems to be working fine, I am resorting to ‘group by well’ to get CP to run on multiple workers. The issue seems to be when I don’t use any groups – it just appears to run a single worker (despite saying otherwise at the bottom).