Not getting global properties output

Hi… iam using Biofilm Q software

When i am uploading my confocal image on the Biofilm Q software…and then analysing them for one set of my images, i am unable to get the global biofilm properties. whereas for the other set of images, iam getting both the local as well as global biofilm properties.
how to solve this problem??

Hi Srinivas,

thank you for reaching out to us about this problem.

I think we first need to determine if the global biofilm properties are not calculated at all or if the error appears later, when trying to retrieve them. At which step in your workflow do you notice that they are “missing”? Can you maybe try the following things and give me feedback on the output?

  • Calculate the global biofilm properties for a few images: Are any errors reported in the console?
  • After that, export the properties to an excel sheet using the export view - do they appear in the sheet? Note, that two excel files are generated during the export, you need to check the one that is called “…_global.csv”
  • Load your images in the visualization view, switch from “Single object parameters” to “Global biofilm parameters” in the parameter selection tab and check if they appear in the list

One thing to note is that for the global measurements to be generated, you need to perform the parameter calculation at least once. Even if you don´t want to have any properties measured other than the ones that are inherent to the segmentation, just press the “Calculate object parameters” button without having select anything in the list below.

Let me know if any if the steps suggested above are unclear or if you could use a more detailed explanation on how to perform them. Thank you for putting in the work to report these issues to us and help us solve them :slight_smile:

Best,

Hannah

Hi Hannah,

Thanks for the response. I could get the global parameters when I used the calculate object parameters at each step regardless of whether I was ticking the boxes.
That must have been the mistake that I was doing.

Thanks for the help.
srinivas